Jump to content
Just nu i M3-nätverket

Transmission äter upp allt ram


adzer

Recommended Posts

Jag har ett problem med att torrent klienten Transmission tar allt mitt ram.

När jag startat datorn har ja 1.7GB ram ledig. 300 på used.

Men så fort jag startar transmission och den börjar räkna in filerna i listan så stiger "inactive" ram användningen till 1.7GB och jag får 10MB ledigt. Jag får då konstant badbollar vad jag än försöker göra.

Stänger jag av Transmission får jag inte tillbaka ramet.

 

Vad är det för fel? Finns det någon bättre klient?

Link to comment
Share on other sites

Der är OS X "fantastiska" minneshantering som sköter om det hela. Inactive betyder att det kan friställas som ledigt om det behövs, det kan ta tid ibland. Det finns ett program Som heter iFreemem som du kan testa.

Link to comment
Share on other sites

Det fungerar riktigt dåligt iaf då jag får badbollar hela tiden och datorn blir överseg.

Jag skall testa ifreemem.

 

 

edit. visst ifreemem fria en massa ram, men inactive ramet stiger direkt efter igen. Även om det tar en stund så tar ramet slut igen utan att jag har något igång som drar ramet mer än transmission.

Link to comment
Share on other sites

Har du många filer igång i Transan kan det ju också slöa ner det hela. Azun blir i alla fall slö på min PM G5 2X2GHz 8GB när det blir över 200 filer igång. Däremot kör jag inget annat på den så det rullar på bra även om om den "blåar" ut minnet. Kan tänka mig att om man börjar photoshoppa samtidigt med någon större bildfil samtidigt så kan det bli lite badbollar. Tycker att det borde gå att ändra i OS X så att den friställer lite mer minne när det ändå finns gott om minne.

Link to comment
Share on other sites

Jag har ett problem med att torrent klienten Transmission tar allt mitt ram.

När jag startat datorn har ja 1.7GB ram ledig. 300 på used.

Men så fort jag startar transmission och den börjar räkna in filerna i listan så stiger "inactive" ram användningen till 1.7GB och jag får 10MB ledigt. Jag får då konstant badbollar vad jag än försöker göra.

Stänger jag av Transmission får jag inte tillbaka ramet.

 

Vad är det för fel? Finns det någon bättre klient?

Jag kan skriva under på att det är en programmeringsbugg! När Transmission uppdaterades nu senast till 1.32 så började programmet direkt att krångla. Den äter upp allt minne och struntar i tid och i otid att bry sig om den maximala uppladdningshastigheten (vilket jag satt max 75 kb/s). Allt fungerade utmärkt tidigare, men så kom då uppdateringen och programmets stabilitet gick i golvet.

 

Vi väntar tålmodigt på en uppdatering.

Link to comment
Share on other sites

Jag kan skriva under på att det är en programmeringsbugg! När Transmission uppdaterades nu senast till 1.32 så började programmet direkt att krångla. Den äter upp allt minne och struntar i tid och i otid att bry sig om den maximala uppladdningshastigheten (vilket jag satt max 75 kb/s). Allt fungerade utmärkt tidigare, men så kom då uppdateringen och programmets stabilitet gick i golvet.

 

Vi väntar tålmodigt på en uppdatering.

Haft samma fel med laddade ner deras SVN fil, dvs det de arbetar med för tillfället, de ahr en sida där de packar ihop de senaste versionen som buggfixar med mera. Och nu fungerar de felfri.

 

Ni kan ladda ner den så länge på: http://transmission.xpjets.com/

Link to comment
Share on other sites

Haft samma fel med laddade ner deras SVN fil, dvs det de arbetar med för tillfället, de ahr en sida där de packar ihop de senaste versionen som buggfixar med mera. Och nu fungerar de felfri.

 

Ni kan ladda ner den så länge på: http://transmission.xpjets.com/

Bra tips!

 

Edit: Nu har jag provat att tagit ned den senaste "night build":en och allt fungerar perfekt så här långt! Jag rekommenderar ni andra att göra samma sak. Än en gång, tack för ett bra tips!

Link to comment
Share on other sites

Samma här efter senaste versionerna. Badbollar och känns som all CPU går åt. Safari krashar och enbart när transmision är aktivt. Ska pröva tipset ovan..

Link to comment
Share on other sites

Efter hårdtestande så kan jag säga att programmet generellt sett är mer stabilare än det var tidigare, men uppladdningsgränsen jag satt till max 75 kb/s hålls inte! Det går mellan 50-90 kb/s, och skulle jag släppa lös uppladdningshastigheten fri (jag avmarkerar sköldpadde-knappen) och sedan aktiverar funktionen igen, så går aldrig programmet tillbaka till max 75 kb/s (eller ens de flytande hastigheterna på mellan 50-90 kb/s).

 

Men så kör vi ju betan av nästa version, så vi borde inte hänga läpp! Vad vi dock kommit fram till är att om man hade oturen att uppdatera Transmission till senaste, "stabila" version 1.32 så bör man uppdatera programmet igen, till det senaste nattliga bygget. Länk: http://transmission.xpjets.com/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...