Jump to content
Just nu i M3-nätverket

Gamla spel (från början av 90-talet) och leopard


Aeneas

Recommended Posts

Jag har nyligen köpt en macbook, med leopard, och tänkte gräva fram mina gamla härliga LucasArts-spel från tidigt nittiotal. Jag har inte haft mac sen typ 1997, så huruvida de funkar på andra versioner av mac osx.

 

När jag sätter in spelen i läsaren frå jag upp ett meddelande som lyder:

 

"Du kan inte starta programmet eftersom classic-miljön inte längre stöds"

 

Finns det något sätt att lösa det på?

Link to comment
Share on other sites

Nej, med till visshet ogrundad erfarenhet.

Kör du Intel och Leopard är det kört, om det nu inte på marknaden dykt upp några virtuella varianter?

Link to comment
Share on other sites

Mr Potato head

Vet inte om du vill ha det långa svaret, men du får det ändå så behöver du ju inte läsa allt om du inte vill. Det korta svaret, om du bara undrar om LucasArts spel, är att spelmotorn för flera av dessa är portad till OS X och det enda du behöver är originalspelet för att sedan köra "native" på din dator. Kolla in: ScummVM

 

-

 

Gamla spel går generellt sett inte att spela rakt av. Applikationer skrivna för PPC (för OS X eller "carbonized" OS9) emuleras mha Rosetta på din intel-dator. Det som är skrivet för OS 9 och lägre körs genom Classic i OS X på PPC-datorer, men fungerar inte på intel, därför får du meddelandet att "classic-miljön inte längre stöds". Classic-miljön stöds inte heller i Leopard på PPC.

 

Alternativet till Classic för intel heter SheepShaver. Basilisk II finns också men har för mig att SS är bättre. Operativsystemet körs i en ruta och det stödjer MacOS 7.5.2 till MacOS 9.0.4. För de äldsta spelen tror jag Mac Plus-emulatorn vMac är bäst. Stödjer MacOS 1.1 till 7.5.5.

 

Förutom emulatorer ska man tänka på att flera gamla klassiker har släppts som öppen källkod, dessa har sedan portats.

Exempel:

Doom

Duke Nukem 3D

Marathon

 

http://en.wikipedia.org/wiki/Category:Free_game_engines

Link to comment
Share on other sites

Scumm ville inte riktigt funka, jag har bara använt det på PC förut och där funkade det otippat nog ganska ganska knaggligt. Jag har dock inte lyckats hitta nån vettig guide för att få det att funka.

 

Men jag tror att det som skulle passa mig bäst vore classic-emulatorerna, eftersom att jag har en del gamla Bullfrog-klassiker jag gärna skulle vilja spela igen.

 

Och för att få SheepSaver och Basilisk att funka så måste jag ha en gammal mac os-installationsskiva, som jag förstått det. Hmm... Får leta lite på vinden och se vad jag kan skramla fram.

 

Tack för hjälpen!

Link to comment
Share on other sites

Mr Potato head
Scumm ville inte riktigt funka, jag har bara använt det på PC förut och där funkade det otippat nog ganska ganska knaggligt. Jag har dock inte lyckats hitta nån vettig guide för att få det att funka.

Konstigt. I den utsträckning jag har provat har det fungerat utan problem. Var det längesedan?

Link to comment
Share on other sites

Carlisle_united

SkummVM har för mig funkat klanderfritt på alla plattformar... Mac, Palm och iPhone.

Den senaste versionen har ju även stöd för dom flesta gamla SIERRA spelen.

Link to comment
Share on other sites

Konstigt. I den utsträckning jag har provat har det fungerat utan problem. Var det längesedan?

 

Ja, det var flera år sen jag använde det på pc. Har fått det att funka på macen nu iaf, jag dummade mig lite när jag försökte få igång spelen bara.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...