Just nu i M3-nätverket
Gå till innehåll
Lagerdahl

Mac Pro 2010, grafik och MacOS

Rekommendera Poster

Hej alla pålästa människor.

Jag kör Mac Pro från mitten 2010 (5.1) med Sierra installerat.

Nyligen uppgraderade jag grafikkortet till ett Radeon RX580, för att kunna köra en ny ritskärm. Det fungerar bra.

 

Vad jag däremot inte blir klok på: grafikkortet är metal-kompatibelt. Då antog jag att jag skulle kunna uppgradera MacOS (så sa reklamen), men det verkar inte alls funka. Programuppdateringen vill inte alls kännas vid någon kompatibilitet med senare OS än Sierra.

 

Vad har jag missförstått?

 

Skärmavbild 2020-01-13 kl. 17.28.14.png

Skärmavbild 2020-01-13 kl. 17.28.53.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du uppdaterar via Appstore - inte programuppdateringen - där har du Catalina.

 

Vilket MacOS är du ute efter?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag är ute nog bara ute efter en senare version av MacOS då några av mina Adobeprogram inte längre kan uppdateras pga för gammalt OS.

 

Appstore vill inte ge mig Catalina dessvärre. Kan ej installeras på min dator tydligen. Vad hette förra versionen av MacOS?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Systemkraven säger att Catalina kräver MacPro från 2013.

Men jag vill minnas att jag läst att min Macpro från 2010 duger om bara grafiken är "stöder metal" (vad nu det betyder?).

Måste man lura programuppdateringen på nåt vis?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har inte alls samma burk som du, bara ungefär lika gammal; jag skulle satsa på Mojave. (Kör det just nu, efter uppgradering från Sierra, på min huvuddator)

 

Förhoppningsvis kan du få High Sierra eller Mojave att installera med hjälp av länkarna ovan.

 

Däremot har jag för mig att Mac Pro 2010 kräver en firmwareuppdatering för att klara High Sierra och Mojave (för att boota från APFS kanske, det nya filsystemet). Och den firmwareuppdateringen kan ibland vägra installera om man har ett grafikkort som inte är "godkänt" av Apple. Jag kan för lite om grafikkort till Mac, men det kan vara det som strular.
 

 

Tänkbar lösning alltså, om ingen annan kommer på något smart : sätt tillbaks det ursprungliga grafikkortet, försök sedan uppdatera till High Sierra eller Mojave, sätt sedan i det nya snabbare kortet - därefter kanske du kan få in Catalina fast frågan är om just Catalina är värt besväret just nu. Jag kör det på en Macbook, och det är väl rätt ok, men jag föredrar ändå Mojave tills vidare. Och HFS+ framför APFS, men det är en annan fråga.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
13 minuter sedan, poi ran säger:

Jag har inte alls samma burk som du, bara ungefär lika gammal; jag skulle satsa på Mojave. (Kör det just nu, efter uppgradering från Sierra, på min huvuddator)

 

Förhoppningsvis kan du få High Sierra eller Mojave att installera med hjälp av länkarna ovan.

 

Däremot har jag för mig att Mac Pro 2010 kräver en firmwareuppdatering för att klara High Sierra och Mojave (för att boota från APFS kanske, det nya filsystemet). Och den firmwareuppdateringen kan ibland vägra installera om man har ett grafikkort som inte är "godkänt" av Apple. Jag kan för lite om grafikkort till Mac, men det kan vara det som strular.
 

 

Tänkbar lösning alltså, om ingen annan kommer på något smart : sätt tillbaks det ursprungliga grafikkortet, försök sedan uppdatera till High Sierra eller Mojave, sätt sedan i det nya snabbare kortet - därefter kanske du kan få in Catalina fast frågan är om just Catalina är värt besväret just nu. Jag kör det på en Macbook, och det är väl rätt ok, men jag föredrar ändå Mojave tills vidare. Och HFS+ framför APFS, men det är en annan fråga.

Jag tolkar att han har redan firmware uppdateringen eftersom hans Mac Pro är av model 5.1

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du kanske är hjälpt av det här, från när jag installerade mojave på min macpro 5.1

Firmware update behövs.

se speciellt min länkar i första inlägget i tråden.

Catalina fungerar inte!

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

MacPro 5.1 verkar lite jobbig. Borde gå i systemrapporten att se om man har rätt boot rom redan.

 

Länkar till lååång tråd. Ögnade lite, tycks som att man ska ta hem High Sierra från app store och installera det innan man ger sig på Mojave.


https://forums.macrumors.com/threads/mp5-1-what-you-have-to-do-to-upgrade-to-mojave-bootrom-upgrade-instructions-thread.2142418/

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
16 timmar sedan, poi ran säger:

Jag har inte alls samma burk som du, bara ungefär lika gammal; jag skulle satsa på Mojave. (Kör det just nu, efter uppgradering från Sierra, på min huvuddator)

 

Förhoppningsvis kan du få High Sierra eller Mojave att installera med hjälp av länkarna ovan.

 

Däremot har jag för mig att Mac Pro 2010 kräver en firmwareuppdatering för att klara High Sierra och Mojave (för att boota från APFS kanske, det nya filsystemet). Och den firmwareuppdateringen kan ibland vägra installera om man har ett grafikkort som inte är "godkänt" av Apple. Jag kan för lite om grafikkort till Mac, men det kan vara det som strular.
 

 

Tänkbar lösning alltså, om ingen annan kommer på något smart : sätt tillbaks det ursprungliga grafikkortet, försök sedan uppdatera till High Sierra eller Mojave, sätt sedan i det nya snabbare kortet - därefter kanske du kan få in Catalina fast frågan är om just Catalina är värt besväret just nu. Jag kör det på en Macbook, och det är väl rätt ok, men jag föredrar ändå Mojave tills vidare. Och HFS+ framför APFS, men det är en annan fråga.

Tack för svar. Jag gjorde ett försök med High Sierra men såsom poi ran påpekar fastnade installationen i uppdateringen av fast programvara. Eller rättare sagt - när maskinen pipit och startat om vill installationen inte gå vidare utan begär uppdatering av fast programvara igen.

Funderar på om jag ska trycka i det gamla kortet och försöka igen.

 

 

Skärmavbild 2020-01-14 kl. 14.21.07.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 timmar sedan, Lagerdahl säger:

Tack för svar. Jag gjorde ett försök med High Sierra men såsom poi ran påpekar fastnade installationen i uppdateringen av fast programvara. Eller rättare sagt - när maskinen pipit och startat om vill installationen inte gå vidare utan begär uppdatering av fast programvara igen.

Funderar på om jag ska trycka i det gamla kortet och försöka igen.

 

 

Skärmavbild 2020-01-14 kl. 14.21.07.png

Jag fastnade där också, men löste det... har för mig att jag stängde av med strömbrytaren och sedan höll inne strömbrytaren tills lampan började blinka.

”Stäng av” i dialogen stänger inte av datorn.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nu har jag lyckats uppdatera till High Sierra. Gjorde som poi ran föreslog - bytte tillbaka till standardgrafikkortet, installerade High Sierra och bytte sedan till nya grafikkortet igen.

 

Lustigt nog verkar OS kommunicera bättre med nya kortet nu - i systemrapporten finns nu "rätt" namn på grafiken. Innan stod det AMD R9 xxx istället för Radeon RX580. Det känns ju bättre.

Skärmavbild 2020-01-14 kl. 17.25.00.png

  • Gilla 2

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...