Jump to content
Just nu i M3-nätverket

Komma åt apacheserver lokalt?


lime90

Recommended Posts

Har installerat en Ubuntu Server på en gammal PC jag haft liggande. Har fått apache2 server att lira ganska bra. Dock så kan jag inte komma åt hemsidan lokalt när jag skapar en ny site. Default kan jag komma åt lokalt via dess ip 10.0.1.11:80. Men när jag skapar en ny sida så går det inte längre.

 

Jag kan alltid komma åt sidorna utifrån via min egna ip som jag portat till servern.

 

Hur gör jag för att komma åt min nya sida lokalt?

Link to comment
Share on other sites

  • 2 weeks later...
Martin_iPhone

Då du kör lokalt (ip 10.0.1.11:80.) så kommer du till default hosten, vill du ha flera sidor på servern så måste du lägga in webbsidan med dns namn (ServerName doman.se ServerAlias www.doman.se) byt då ut doman.se mot den domänmen du har.

 

då nya sites ligger som vhosts, så man kan ha flera domäner på samma server (och ip adress).

 

Om doman.se funkar då du mappar via att skriva det i webbläsaren så lägg antingen in ett lokalt dns namn i din hosts fil, som pekar med doman.se mot direkt mot interna ip adressen på servern. alternativt, lägg upp en extra port påservern (Listen 8080) på ditt interna gränssnitt i på servern (din interna ip) på den vhosten du vill ha, starta sen om apache.

 

gå sen då in på ipnummer:8080

Link to comment
Share on other sites

  • 5 weeks later...

Viktigt är att du lägger till dessa domäner även lokalt på din maskin (inte servern).

I t.ex XP finns det en fil som heter hosts där lägger du till det ip som du har till din server och sedan den domän som ska användas.

 

Sedan i din apache server lägger du till en vhost med det ip som servern lyssnar på, det vill säga sitt eget, och sedan vilken domän som ska gå till vilken mapp/site.

Glöm bara inte att aktivera vhosts i apache config.

 

Blev säkert lite kaka på kaka där med det förra inlägget men alla förklarar vi saker på olika sätt :P

Link to comment
Share on other sites

Jag fick det att fungera. Var lite småfel bara som löstes ganska enkelt.

Link to comment
Share on other sites

  • 6 months later...

Jag har försökt att få igång apache men inte lyckats så bra. Har något problem med ssl. Har någon en bra guide som ni har följt och fått det att fungera?

Jag har följt några olika men aldrig fått till det. Kan även tillägga att mina linux kunskaper är ganska begränsade.

 

Men tips på guider skulle uppskattas.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...