Jump to content
Just nu i M3-nätverket

Hur löser man operatörs-låsningen på iPhone på bästa sätt?


senic

Recommended Posts

Hej

 

Har idag köpt en iPhone 3G och har under kvällen letat runt på forum, google, bloggar och små elektronikföretags hemsidor för att hitta den bästa lösningen på problemet att telefonen är låst till Telia. Det vanligaste sättet att lösa det på verkar vara att "jailbreaka" för att sedan låsa upp den.

 

Jag hittade även ett sätt att manipulera simkorten genom att köpa ett tunt simkort som man stoppar in tillsammans med sitt "vanliga" simkort. Exempel på dessa är RebelSIM, i-SmartPhone 3G Sim Unlock Card etc. Detta tyckte jag var den spontant bästa lösningen då man inte behövde göra något med mjukvara i telefonen.

 

 

Att använda "jailbreak" tekniken är som sagt tydligen ganska vanligt och verkar fungera bra. Men är det någon som har testat med dessa simkort? Jag är lite intresserad hur dom fungerar och var man kan få tag på ett sådant.

 

 

Vad är fördelen respektive nackdelen med dessa två "tekniker"? Finns det fler sätt att lösa "det hemska Telia problemet" på?

 

Tack på förhand!

Link to comment
Share on other sites

FredrikBergstrom

Om du vill kunna använda din iPhone 3G med andra operatörer gäller det att du INTE har version 2.2.1 i den, utan du måste ha 2.2 (sedan kan du uppdatera till 2.2.1 på ett speciellt sätt, läs i guiden). Det kan du se under Inställningar-->Allmänt-->Om. Har du 2.2 i den är det bara att följa den här guiden, som du får för att jag ska slippa skriva den själv här, guider finns trots allt där och på 100-tals andra ställen. Eftersom du inte är insatt i iPhone så rekommenderar jag att du läser igenom hela guiden innan du sätter igång.

 

EDIT: För att svara på din fråga om de små korten så låter de telefonen tro att det är ett godkänt simkort som sitter i. Vissa tycker de fungerar super, andra tycker de är totalt värdelösa, sen finns det personer på alla steg där mellan. Själv hör jag till de som tycker de är värdelösa och föredrar det jag skriver om ovan. Men har du 2.2.1 i den redan så kanske du får ge de små korten en chans trots allt.

 

EDIT 2: Kommer på saker du bör veta efter hand. Tänkte bara nämna att om du råkar ha 2.2.1 i så kan du i alla fall jailbreaka den, med det menas att du kan installera applikationer som inte är godkända av Apple, komma åt filsystemet etc.

 

Sammanfattningsvis:

Aktivera = få bort en "Please Activate"-ruta så att du kan använda alla funktioner som vanligt.

Jailbreaka = Åtkomst till hela systemet vilket möjliggör installation av andra saker än Apple har tillåtit.

Upplåsning = Möjliggör användande av andra operatörer.

Link to comment
Share on other sites

Tack, bra info för en nybörjare som jag. Har lite fler funderingar som jag uppskattar att få hjälp till

 

 

Finns risken att jag har 2.2.1 i telefonen från butik nu? Jag har inte ens öppnat den och kontrollerat då jag dumt nog kastade Telia simkortet jag fick med. Måste fixa ett nytt idag.

 

Om det nu är så att jag har 2.2 i telefonen, visst måste jag jailbreaka telefonen innan jag låser upp den?

Om det nu är så att jag har 2.2.1 i telefonen, går det att nedgradera mjukvaran i telefonen på något sätt? Eller är enda lösningen då att köra med speciella simkort?

Link to comment
Share on other sites

Tack, bra info för en nybörjare som jag. Har lite fler funderingar som jag uppskattar att få hjälp till

 

 

Finns risken att jag har 2.2.1 i telefonen från butik nu? Jag har inte ens öppnat den och kontrollerat då jag dumt nog kastade Telia simkortet jag fick med. Måste fixa ett nytt idag.

 

Om det nu är så att jag har 2.2 i telefonen, visst måste jag jailbreaka telefonen innan jag låser upp den?

Om det nu är så att jag har 2.2.1 i telefonen, går det att nedgradera mjukvaran i telefonen på något sätt? Eller är enda lösningen då att köra med speciella simkort?

 

Köpte du den de senaste två veckorna har du 2.2.1 i den redan.

Link to comment
Share on other sites

Tack, bra info för en nybörjare som jag. Har lite fler funderingar som jag uppskattar att få hjälp till

 

 

Finns risken att jag har 2.2.1 i telefonen från butik nu? Jag har inte ens öppnat den och kontrollerat då jag dumt nog kastade Telia simkortet jag fick med. Måste fixa ett nytt idag.

 

Om det nu är så att jag har 2.2 i telefonen, visst måste jag jailbreaka telefonen innan jag låser upp den?

Om det nu är så att jag har 2.2.1 i telefonen, går det att nedgradera mjukvaran i telefonen på något sätt? Eller är enda lösningen då att köra med speciella simkort?

 

Du har troligtvis 2.2.1, och det går inte att nedgradera. Men om du ska köra jailbreak så måste du inte ha ett giltigt simkort för att aktivera :)

Link to comment
Share on other sites

FredrikBergstrom
Tack, bra info för en nybörjare som jag. Har lite fler funderingar som jag uppskattar att få hjälp till

 

 

Finns risken att jag har 2.2.1 i telefonen från butik nu? Jag har inte ens öppnat den och kontrollerat då jag dumt nog kastade Telia simkortet jag fick med. Måste fixa ett nytt idag.

 

Om det nu är så att jag har 2.2 i telefonen, visst måste jag jailbreaka telefonen innan jag låser upp den?

Om det nu är så att jag har 2.2.1 i telefonen, går det att nedgradera mjukvaran i telefonen på något sätt? Eller är enda lösningen då att köra med speciella simkort?

 

 

Du måste jailbreaka 2.2 innan du kan låsa upp den, eftersom det görs med ett program som installeras i telefonen och självklart inte godkänt av Apple.

 

Enkelt beskrivet är firmware (2.2, 2.2.1 etc) själva operativsystemet och baseband (modem firmware) är det som sköter telefondelen. För att den ska gå att låsa upp (använda med andra operatörer krävs baseband 02.28.00, vilket är det baseband som följer med 2.2-uppdateringen.

 

Med hjälp av det Pwnage tool som beskrivs i guiden jag länkade till kan man uppdatera från 2.2 till 2.2.1 UTAN att få med det nya basebandet, vilket gör att du kan köra 2.2.1 upåplåst ändå. Om du har 2.2 i den nu är det alltså i denna ordning du ska göra allt (läs igenom guiden jag länkade till först så förstår du alla steg):

 

1. Du har 2.2 och ska uppdatera till 2.2.1 utan att få med det nya basebandet. Det gör du med Pwnage tool där du skapar en modifierad "installationsfil".

2. Du återställer till den modifierade filen från steg 1 i iTunes.

3. Nu har du en jailbreakad 2.2.1 och kan därför installera upplåsningsprogrammet Yellowsn0w.

4. Klart!

 

Svar på din sista fråga: Du kan inte nedgradera basebandet, vilket gör att om du har 2.2.1 direkt från Apple så kommer du inte ha hjälp av att nedgradera till 2.2 - Du kommer fortfarande ha det nya basebandet som kom med 2.2.1 och därför inte kunna låsa upp den.

Link to comment
Share on other sites

Köpte du den de senaste två veckorna har du 2.2.1 i den redan.

Det stämmer inte. Om han har fått en iPhone som gjorts under den senaste månaden (ungefär) har han 2.2.1, men troligtvis har ju affärerna kvar iPhones på lager, som har ett äldre firmware installerat.

 

Du kan hur som helst, lätt kolla vad du har för baseband.

 

Inställningar -> Allmänt -> Om -> Modemfirmware

 

Om du har modemfirmware 02.28.00 är du good to go. Högre än det, så fungerar det inte att låsa upp via jailbreak.

Link to comment
Share on other sites

Bästa "tekniken" är nog att köpa sin iPhone i Norge och där betala för en officiell upplåsning (vilket kostar runt 2 500 norska kr). Dock måste man betala första månadsavgiften för de abonnemang som den säljs via. En iPhone 8G ligger på runt 4 200 norska, upplåst och klar - vilket motsvarar drygt 5 500 svenska kr. Säljs av Netcom.

 

I Norge får man inte ha abonnemang som är låsta utan möjlighet till upplåsning, därför kan man i Norge låsa upp telefonen under bindningstiden - om än mot en hög avgift. I Sverige får man ha låsta abonnemang och här har vi inte möjligheten låsa upp telefonen före bindningstidens utgång.

 

Norge är bäst. :)

Link to comment
Share on other sites

Tack för all info, den uppskattas!

 

 

Till min stora besvikelse så är det redan version 2.2.1 i den och Modemfirmware 02.30.03 nu när jag starta igång den :(

 

Vad är mina alternativ då? Är det bara Telia som gäller nu eller har jag några alternativ? Ska man testa med ett manipulerat simkort?

Link to comment
Share on other sites

Tack för all info, den uppskattas!

 

 

Till min stora besvikelse så är det redan version 2.2.1 i den och Modemfirmware 02.30.03 nu när jag starta igång den :(

 

Vad är mina alternativ då? Är det bara Telia som gäller nu eller har jag några alternativ? Ska man testa med ett manipulerat simkort?

 

Det verkar inte som om de fejkade simkorten fungerar med modemfirmware 02.30.03 heller... Troligen är det bara att ta det lugnt och vänta på nästa version av Yellowsn0w... :(

Link to comment
Share on other sites

Ajdå, det var surt!

 

Är det någon som vet något eller hört något om när nästa version av yellowsn0w kommer så jag kan lösa mina problem?

 

Nu är det ju lite surt att jag sålde min Nokia 5800 för 3 timmare sedan...

Link to comment
Share on other sites

Ajdå, det var surt!

 

Är det någon som vet något eller hört något om när nästa version av yellowsn0w kommer så jag kan lösa mina problem?

 

Nu är det ju lite surt att jag sålde min Nokia 5800 för 3 timmare sedan...

 

http://blog.iphone-dev.org/

Link to comment
Share on other sites

Ajdå, det var surt!

 

Är det någon som vet något eller hört något om när nästa version av yellowsn0w kommer så jag kan lösa mina problem?

 

Vad jag har hört så finns det redan en för 02.30.03, men de vill inte släppa den. Strax efter de släppte yellowsn0w för 02.28.00 så täppte ju Apple till det lilla maskhålet de hittat. Så dev-team släpper troligen inget före iPhone OS 3.0, för annars finns en risk för att 3.0-basebandet aldrig blir upplåst ;) Så den som väntar på nått gott, måste vänta länge :)

Link to comment
Share on other sites

Vad jag har hört så finns det redan en för 02.30.03, men de vill inte släppa den. Strax efter de släppte yellowsn0w för 02.28.00 så täppte ju Apple till det lilla maskhålet de hittat. Så dev-team släpper troligen inget före iPhone OS 3.0, för annars finns en risk för att 3.0-basebandet aldrig blir upplåst ;) Så den som väntar på nått gott, måste vänta länge :)

 

Källa?

Link to comment
Share on other sites

Vad jag har hört så finns det redan en för 02.30.03, men de vill inte släppa den. Strax efter de släppte yellowsn0w för 02.28.00 så täppte ju Apple till det lilla maskhålet de hittat. Så dev-team släpper troligen inget före iPhone OS 3.0, för annars finns en risk för att 3.0-basebandet aldrig blir upplåst ;) Så den som väntar på nått gott, måste vänta länge :)

 

 

Hur vet du det?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...