Jump to content
Just nu i M3-nätverket

Gmail i iPhone


beckasin

Recommended Posts

När jag mailar från iPhonen så säger mottagarna att texten blir delvis kryptisk. Någon som har en bra förklaring till vad som kan vara fel, använder gmail. :superirriterad:

Link to comment
Share on other sites

Kan du bifoga hur mailet ser ut för din kompis? Låter ju som det har med teckenkodningen att göra, men jag vet även att detta inte går att ställa in i mailklienten på telefonen. Vet däremot att ma kan ändra detta i webbklienten under inställningar. Då kan man välja att använda unicode eller standardformatering. Börja med att se till att du inte valt unicode (UTF-8). Å andra sidan så bör det vara så att om det är teckenkodningen som är felet så berör det endast de som har mailklienter eller datorer som inte stödjer unicode. Vet du om problemet gäller alla mottagare eller endast denna?

Link to comment
Share on other sites

Kan du bifoga hur mailet ser ut för din kompis? Låter ju som det har med teckenkodningen att göra, men jag vet även att detta inte går att ställa in i mailklienten på telefonen. Vet däremot att ma kan ändra detta i webbklienten under inställningar. Då kan man välja att använda unicode eller standardformatering. Börja med att se till att du inte valt unicode (UTF-8). Å andra sidan så bör det vara så att om det är teckenkodningen som är felet så berör det endast de som har mailklienter eller datorer som inte stödjer unicode. Vet du om problemet gäller alla mottagare eller endast denna?

 

Ser ut så här: "Inger Malmö" och Subject: Snö. Jag har inte valt UTF-8

Jag har 2 mottagare som klagat

Link to comment
Share on other sites

Onekligen är det teckenkodningen som strular då det är just å ä och ö som inte visas rätt.

 

Kolla vad det står i headers för mailet. Om du själv använder Gmail så kan du logga in på din dator, öppna mailet du skickade, klicka på pilen högst uppe till höger och väl "Visa original". Kolla där raderna längst ned i headern, bör se ut så här:

 

User-Agent: SquirrelMail/1.4.13

MIME-Version: 1.0

Content-Type: text/plain;charset=iso-8859-1

Content-Transfer-Encoding: 8bit

Link to comment
Share on other sites

Onekligen är det teckenkodningen som strular då det är just å ä och ö som inte visas rätt.

 

Kolla vad det står i headers för mailet. Om du själv använder Gmail så kan du logga in på din dator, öppna mailet du skickade, klicka på pilen högst uppe till höger och väl "Visa original". Kolla där raderna längst ned i headern, bör se ut så här:

 

User-Agent: SquirrelMail/1.4.13

MIME-Version: 1.0

Content-Type: text/plain;charset=iso-8859-1

Content-Transfer-Encoding: 8bit

 

Tack för du tar dig tid! Jag har mime-version 1.0

Jag har ej iso 8859-1 utan us-ascii; format-flowed

Har ej 8-bit utan 7 bit

Hittade ingen user-agent

Link to comment
Share on other sites

Nu har jag testat att skicka mail från iPhonen till min outlook i datorn. Det är när jag bifogar bilder som det blir kryptiska tecken, inte annars.

Link to comment
Share on other sites

Vad dumt att det blir så. Det är ju avsaknaden av ISO-8859 som gör att tecknen inte visas, varför det blir så vågar jag inte svara på. Eller, jo, det har väl att göra med att överföringen för bilderna sker via ascii, men hur man ändrar det vet jag inte. Har inte samma problem med min iPhone när jag skickar bilder (vad jag vet). Jag hojtar till om jag hittar en lösning.

Link to comment
Share on other sites

  • 4 weeks later...

Försöker att lyfta upp den här tråden. Tycker att det är konstigt att ingen annan får problem när de skickar bilder och skriver åäö :fundersam: Jag har givetvis googlat om eländet, får väl undvika åäö om jag ej hittar en lösning :deppig:

Link to comment
Share on other sites

Jag har ej iso 8859-1 utan us-ascii; format-flowed

Har ej 8-bit utan 7 bit

 

Där finns svaret.

I 7-bitars US Ascii så finns inte svenska tecken.

Ascii = teckenuppsättning. US = Amerikansk.

7-bitars = tecken 0-127, alltså 128 tecken allt som allt.

8 bitars = tecken 0 - 255.

Det får inte plats åäö på 7-bitars US-Ascii, ryms inte helt enkelt.

Du måste ha 8 bitars, och kör med annan Ascii än US.

Link to comment
Share on other sites

Där finns svaret.

I 7-bitars US Ascii så finns inte svenska tecken.

Ascii = teckenuppsättning. US = Amerikansk.

7-bitars = tecken 0-127, alltså 128 tecken allt som allt.

8 bitars = tecken 0 - 255.

Det får inte plats åäö på 7-bitars US-Ascii, ryms inte helt enkelt.

Du måste ha 8 bitars, och kör med annan Ascii än US.

 

Då blir det en följdfråga, kan jag ändra det och i så fall var?

Link to comment
Share on other sites

  • 1 year later...

Gammal tråd men nu lånar jag den... Jag har gmail via imap i iphonen utan problem, kalendrarna har jag via gmail exchange utan problem, men när jag testar att köra mailen via gmail exchange istället för imap så blir alla åäö konstiga tecken i de mail jag får... hur löser man detta?

Link to comment
Share on other sites

..å jag får fortfarande sådana här tecken när jag skickar bilder från iPhonen, Ã-öö ååå ööö III( om jag använder å, ä och ö.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...