Jump to content
Just nu i M3-nätverket

Boot-problem efter installation av Safari 4 beta


kronman

Recommended Posts

Hej alla mac-kunniga,

jag har en MacBook Pro som är 2 år och kör OS X 10.4.11 (Tiger) och jag har börjat få problem med att den (ibland) inte vill boota.

 

Problemen uppstod (eller upptäcktes) när jag höll på och trasslade med installationen av Safari 4 beta - jag hade krånglande tillägg som behövde avinstalleras - men jag är inte säker på att det är installationen av Safari 4 som är själva huvudproblemet.

 

Symptomen är följande: När jag slår på eller startar om macen hör jag inget startljud och sedan hamnar datorn i ett läge där skärmen är helt svart och inget händer. Om man väntar ett tag kan man höra att CPUn jobbar, för fläktarna spinner upp, men inget annat händer. Det verkar också som om datorn befinner sig i ett helt dött läge och inte känner av vare sig tangentbord eller CD. Jag har försökt nollställa parameterminnet och försökt boota från installations-CDn men inget sådant funkar. Den enda knapp som datorn reagerar på är power-knappen, med vilken jag kan tvångsavstänga den och starta den.

 

Ibland löser problemet sig av sig självt om man väntar ett tag. Ibland kan jag lösa problemet genom att plugga i en backupdisk via FireWire och då bootar datorn upp via den vanliga hårddisken.

 

För mig framstår det som att det är något i ROM/BIOS (eller vad det heter på mac) som har kommit i olag, men det verkar så konstigt att problemet uppträder så sporadiskt.

 

Är det någon som har sett något likande och kan tipsa mig om vad det är som orsakar detta problem?

 

Jag skulle ju kunna installera om systemet för att se om det hjälper, men eftersom jag använder burken som utvecklingsmaskin och har installerat Apache, Django, Python, PostgreSQL etc. med MacPorts vill helst inte blåsa ur den miljön, för det tog någon vecka att få till den med alla installationer och konfigureringar.

 

(Edit: Ursäkta den fåniga rubriken, men jag visste faktiskt inte att systemet lägger till beskrivningen efter rubriken och att man dessutom inte kan redigera beskrivningen)

 

Tacksam för hjälp,

Uffe

Link to comment
Share on other sites

Stereotypen

Du kn ju installer om alternativet med "Spara och installera".

Då installerar maskinen bara om OSX medans dina andra program och instöllningar finns kvar.

 

Mvh

Link to comment
Share on other sites

Du kn ju installer om alternativet med "Spara och installera".

Då installerar maskinen bara om OSX medans dina andra program och instöllningar finns kvar.

 

Tack för tipset. Det heter visst "Arkivera och installera" och beskrivs just nu på WacWorld-webben, men det jag undrar är om denna funktion verkligen förstår sig på att lägga tillbaks saker som ligger i /opt/local/ och systemnära konfigureringar man gjort i filerna i /etc

Förr eller senare kommer jag iallafall att behöva göra detta när jag ska upp till Leopard, så det kan vara bra att veta.

 

Nu tror jag iofs. inte att det är något problem i operativsystemet, eftersom datorn ju aldrig hinner fram till stadiet att börja läsa in operativsystemet. Min uppfattning är att datorn inte rör hårddisken överhuvudtaget när den fastnar i det här läget.

 

Jag tror snarare det är ett hårdvaruproblem och att det är något moment i hårdvarukontrollen som hänger upp sig. Jag tycker mig märka att det oftast löser sig om man låter macen vila avstängd ett tag = svalnar av. Det kan tyda på något glapp som skapas av uppvärmning.

 

Jag har hittat någon med motsvarande symptom här:

http://forums.macrumors.com/archive/index.php/t-486702.html

 

Jag ska nog försöka mig på en hardware test, dvs. hålla ned D-tangenten medan datorn bootar för att se om den indikerar något fel på DIMMarna eller så (2*1GB RAM installerat från fabrik).

 

Under tiden har jag nu lyckats nollställa PRAM (cmd-alt-P-R vid uppstart) och har avinstallerat en utility som jag hade som sätter volymen på startljudet för att eliminera den komplikationen.

 

// Uffe

Link to comment
Share on other sites

Prova att göra en SMC-reset också..

http://support.apple.com/kb/HT1411?viewlocale=sv_SE

 

Tack även för detta tips. Jag kanske provar det framöver.

 

Jag har nu kört Apple Hardware Test (sätt i OS DVDn och håll ned tangent D när datorn bootar) och fått verifierat att det är fel på den ena av mina minneskretsar. Den ger fel: 4MEM/1/4000000 ...

 

Här finns någon med samma problem som jag:

http://discussions.apple.com/message.jspa?messageID=3741447

 

Det verkar också som om felet bara yttrar sig när datorn är varm för när jag körde det enkla testet med datorn i knäet hittade den fel, men när jag körde det utvidgade testet med datorn stående på ett bord hittade den inget fel, inte heller det enkla testet hittade något fel när datorn stod på bordet.

 

Det stämmer också med symptomen att datorn bootar OK när den fått svalna (och helst står på ett bord, tydligen).

 

Nu har jag ändå inom kort tänkt jacka upp burken till 2*2GB RAM och lägga på Leopard, så jag tror jag kan leva med denna glappande(?) DIMM tillsvidare, nu när jag vet hur den beter sig. Man behöver ju vanligtvis bara boota om någon gång i månaden iallafall (om man nu inte ska installera på och av Safari 4).

 

Tack för hjälpen,

Uffe

Link to comment
Share on other sites

Tack även för detta tips. Jag kanske provar det framöver.

 

Jag har nu kört Apple Hardware Test (sätt i OS DVDn och håll ned tangent D när datorn bootar) och fått verifierat att det är fel på den ena av mina minneskretsar. Den ger fel: 4MEM/1/4000000 ...

 

Här finns någon med samma problem som jag:

http://discussions.apple.com/message.jspa?messageID=3741447

 

Det verkar också som om felet bara yttrar sig när datorn är varm för när jag körde det enkla testet med datorn i knäet hittade den fel, men när jag körde det utvidgade testet med datorn stående på ett bord hittade den inget fel, inte heller det enkla testet hittade något fel när datorn stod på bordet.

 

Det stämmer också med symptomen att datorn bootar OK när den fått svalna (och helst står på ett bord, tydligen).

 

Nu har jag ändå inom kort tänkt jacka upp burken till 2*2GB RAM och lägga på Leopard, så jag tror jag kan leva med denna glappande(?) DIMM tillsvidare, nu när jag vet hur den beter sig. Man behöver ju vanligtvis bara boota om någon gång i månaden iallafall (om man nu inte ska installera på och av Safari 4).

 

Tack för hjälpen,

Uffe

 

Inte bra. Risken finns att du knäcker hårddisken med den varianten.

Link to comment
Share on other sites

Inte bra. Risken finns att du knäcker hårddisken med den varianten.

 

Hmm, det där förstår jag inte riktigt. Kan du förklara hur en ev. glappande DIMM påverkar användningen av hårddisken?

 

Jag märker ju inte av något fel när datorn är igång, utan det är tydligen bara i samband med hårdvarutesten vid omstart som det märks av, om datorn är varm.

 

// Uffe

Link to comment
Share on other sites

Prova att göra en SMC-reset också..

http://support.apple.com/kb/HT1411?viewlocale=sv_SE

 

Tack för tipset. Jag har nu gjort en SMC-reset och det verkade faktiskt som om datorn startade om bättre än förut, men det är svårt att verifiera eftersom felet bara dyker upp ibland (se min beskrivning ovan)

 

// Uffe

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...