Jump to content
Just nu i M3-nätverket

Två iMac:ar klara för skrotning?


Carlbo

Recommended Posts

Hej!

 

Har suttit i drygt en timmes tid och kollat upp det som skrivs här om OS datorer, men inte

hittat något bra svar på min fråga.

 

Jag har två stycken iMac G3 som har lagt av på kort tid, en 300 Mhz och en 400 Mhz.

 

Båda apparaterna har utsatts för strömstötar, den första på grund av ett glapp i eluttaget och den

andra nu i veckan då ljuset blinkade några gånger i snabb följd. Den jänta som har använt datorerna

är ledsen och har svårt att förstå, att det inte var hennes fel att de havererade.

 

När man startar så kommer plinget och man hör att startskivan gör några korta försök, men sedan

stannar allt upp och skärmen är vit. Har försökt alla tips jag känner till, utan resultat.

 

Ibland så fungerar den sista som gick sönder, men då man stänger av den och försöker igen sedan

den blivit kall, så är felet tillbaka och nu verkar också den död och vit i skärmen.

 

Eftersom det inte går att starta från startskivan, så är det väl knappast hårddisken som är skadat,

utan något annat, skulle jag tro, eller har jag fel?

 

Det är nog något i nätdelen som har skadats.

 

Jag tänkte först köpa en ny hårddisk och testa, men det är nog ingen ide utan bara bortkastade pengar.

 

Vad tycker ni, skall jag åka till sopstationen med dessa?

Link to comment
Share on other sites

marcushedenstrom

Jag skulle säga att det inte är värt att lägga några pengar på en så gammal dator.

 

Skulle tro att det är något åt hårddiskens håll som gått sönder, så pröva att starta från en system-CD istället.

Link to comment
Share on other sites

Jag hade ett liknande problem, dock så startade datorn inte alls.

Men fick någon strömpeak i datorn då de åska, så nätagget for och allt runt omkring.

 

Jag skulle då iaf satsa på en ny dator, alt köpa en bättre begagnad, de är upp till var och en.

Link to comment
Share on other sites

Jag skulle säga att det inte är värt att lägga några pengar på en så gammal dator.

 

Skulle tro att det är något åt hårddiskens håll som gått sönder, så pröva att starta från en system-CD istället.

 

Jag skrev lite otydligt, det var med systemskivan jag försökte.

 

Man skall nog inte lägga ner så mycket på dessa gamla datorer,

det är bortkastade pengar då det finns nya och bättre.

 

Kan datorn starta från en systemskiva om hårddisken är sönder?

 

Jag kollade upp priset på en hårddisk på Macoteket och den skulle komma på posten för 605 kr.

Link to comment
Share on other sites

marcushedenstrom
Kan datorn starta från en systemskiva om hårddisken är sönder?

 

Japp.

Link to comment
Share on other sites

Japp.

 

 

Eftersom dessa två inte kan det, så måste således felet vara av annan karaktär

och därför inget som jag själv kan göra något åt, eftersom jag inte har några

kretsbeskrivningar av dom.

 

Får tacka för svaren.

Link to comment
Share on other sites

Eftersom dessa två inte kan det, så måste således felet vara av annan karaktär

och därför inget som jag själv kan göra något åt, eftersom jag inte har några

kretsbeskrivningar av dom.

 

Får tacka för svaren.

 

Kommer du in i open firmware om du håller ner äpple-alt-o-f vid uppstart?

Link to comment
Share on other sites

Kommer du in i open firmware om du håller ner äpple-alt-o-f vid uppstart?

 

Inte med dessa knapp-kombinatioer, men dock med att trycka in den bakre knappen, när jag startar upp,

där de olika uttagen sitter på högra sidan.

 

Man uppmanas där att skriva mac-boot, men skärmen övergår till att vara vit, som tidigare.

Link to comment
Share on other sites

Inte med dessa knapp-kombinatioer, men dock med att trycka in den bakre knappen, när jag startar upp,

där de olika uttagen sitter på högra sidan.

 

Man uppmanas där att skriva mac-boot, men skärmen övergår till att vara vit, som tidigare.

 

Prova skriv reset-nvram i open firmware, och efter detta skriv bye

 

---

 

reset-all kan du prova också.

 

(korrigerade min felvändning hade skrivit nvram-reset innan)

 

Edit2:

 

och sist kan du prova- skriva set-defaults också

 

Om inget av detta fungerar är det hårdvaru fel på datorerna.

Link to comment
Share on other sites

Prova skriv reset-nvram i open firmware, och efter detta skriv bye

 

---

 

reset-all kan du prova också.

 

(korrigerade min felvändning hade skrivit nvram-reset innan)

 

Edit2:

 

och sist kan du prova- skriva set-defaults också

 

Om inget av detta fungerar är det hårdvaru fel på datorerna.

 

Inget tycks hjälpa, men datorn gör ett försök att starta varje gång jag testar

och sedan så stannar den upp.

 

Jag skall senare flytta över denna hårddisk i den andra och testa, för den hårddisken

kom inte upp på skärmen, när jag försökte med systemskivan, vilket denna gjorde,

innan allt blev vitt.

Link to comment
Share on other sites

Jag kollade upp priset på en hårddisk på Macoteket och den skulle komma på posten för 605 kr.

Du vet att det finns billigare ställen va? ;)

Link to comment
Share on other sites

Du vet att det finns billigare ställen va? ;)

 

Det var det enda jag kollade och detta pris är inklusive moms och frakt.

 

Men eftersom inte datorn kan starta upp med systemskivan, så är det

nog ingen ide, skulle jag tro, av det svar jag fick om detta av marcushedenstrom.

Link to comment
Share on other sites

Inget tycks hjälpa, men datorn gör ett försök att starta varje gång jag testar

och sedan så stannar den upp.

 

Jag skall senare flytta över denna hårddisk i den andra och testa, för den hårddisken

kom inte upp på skärmen, när jag försökte med systemskivan, vilket denna gjorde,

innan allt blev vitt.

 

Koppla ur hårddisken och sätt i installations cd:n, risken finns att något runt sydbryggan är skadat.

Link to comment
Share on other sites

Koppla ur hårddisken och sätt i installations cd:n, risken finns att något runt sydbryggan är skadat.

 

Jag gjorde som du sade och då laddar datorn in systemskivan och dess program,

vilket betyder då – Vad kan göras åt detta?

Link to comment
Share on other sites

Hittade lite artiklar om detta med "Sydbrygga":

 

http://mikrodatorn.idg.se/2.1030/1.172325

 

http://www.sweclockers.com/nyhet/8046-ny_s...ckare_svangrum/

 

http://www.sweclockers.com/news_show.php?id=4385

 

Är detta eventuella fel någon man kan göra år, eller det någon krets som är sönder i själva datorn?

Link to comment
Share on other sites

Hittade lite artiklar om detta med "Sydbrygga":

 

http://mikrodatorn.idg.se/2.1030/1.172325

 

http://www.sweclockers.com/nyhet/8046-ny_s...ckare_svangrum/

 

http://www.sweclockers.com/news_show.php?id=4385

 

Är detta eventuella fel någon man kan göra år, eller det någon krets som är sönder i själva datorn?

 

En PCI baserad dator är byggd ungefär så här- Tänk dig detta som ett försök till ett illustrativt diagram :P

 

[Processor] <-> [Nordbrygga] <-> [sydbrygga]

 

Nordbryggan är den "avfart" som processorn använder för att komma åt RAM minne och Grafikkort (Man kan säga att Nordbryggan hanterar höghastighetsdataöverföringar)

 

Sydbryggan är den "avfart" som processorn använder för att komma åt PCI kort, USB, Diskettstation, Hårddiskar, CD/DVD osv

 

Nu är det iofs ganska etablerat att just sydbryggan i sig inte är skadad- och jag försökte inte påvisa detta heller utan det jag menade var att felet måste isåfall ligga någonstans i den regionen- alltså I/O enheter.

 

Personligen tror jag det är hårddiskens styrkrets som gått sönder, men det är som sagt en gissning- samtidigt känns det lite konstigt om båda datorerna fått exakt samma fenomen och båda har problem på exakt samma ställe.

Därför skulle jag vilja göra yttligare en test för att utesluta hårddiskfel.

 

Koppla in hårddisk, starta i openfirmware skriv "boot cd:" när du har installations cd:n i, om detta startar prova installera systemet på nytt.

Jag kan dock inte på rakarm svara på vad det kan vara isåfall, såvida det inte är något gravt fel på RAM minnet- men det känns ganska otroligt då krashen uppenbarligen uppträder innan kärnan ens initialiserats (om kärnan var klar hade du fått en panic)

Därför är det sannolikt att boot processen blir hängande någonstans mellan openfirmware och bootx och kärnan (jag antar det är MacOS X det rör sig om?)

Link to comment
Share on other sites

En PCI baserad dator är byggd ungefär så här- Tänk dig detta som ett försök till ett illustrativt diagram :P

 

[Processor] <-> [Nordbrygga] <-> [sydbrygga]

 

Nordbryggan är den "avfart" som processorn använder för att komma åt RAM minne och Grafikkort (Man kan säga att Nordbryggan hanterar höghastighetsdataöverföringar)

 

Sydbryggan är den "avfart" som processorn använder för att komma åt PCI kort, USB, Diskettstation, Hårddiskar, CD/DVD osv

 

Nu är det iofs ganska etablerat att just sydbryggan i sig inte är skadad- och jag försökte inte påvisa detta heller utan det jag menade var att felet måste isåfall ligga någonstans i den regionen- alltså I/O enheter.

 

Personligen tror jag det är hårddiskens styrkrets som gått sönder, men det är som sagt en gissning- samtidigt känns det lite konstigt om båda datorerna fått exakt samma fenomen och båda har problem på exakt samma ställe.

Därför skulle jag vilja göra yttligare en test för att utesluta hårddiskfel.

 

Koppla in hårddisk, starta i openfirmware skriv "boot cd:" när du har installations cd:n i, om detta startar prova installera systemet på nytt.

Jag kan dock inte på rakarm svara på vad det kan vara isåfall, såvida det inte är något gravt fel på RAM minnet- men det känns ganska otroligt då krashen uppenbarligen uppträder innan kärnan ens initialiserats (om kärnan var klar hade du fått en panic)

Därför är det sannolikt att boot processen blir hängande någonstans mellan openfirmware och bootx och kärnan (jag antar det är MacOS X det rör sig om?)

 

Jag testade i den dator som hårddisken just nu sitter i, men det gick inte att skriva tecknet för kolon :

det kom ett annat tecken i stället.

 

Jag skall plocka ut hårddisken nu och sätta den i den dator som startade utan hårddik med systemskivan.

 

Får tack för det du gjort och hoppas att det skall lösa sig så att jäntan får sin dator.

Link to comment
Share on other sites

Glömde tala om att det är OS 9 det handlar om.

 

Vet någon hur man i detta läge (openfirmware) skriver ett kolon : ?

 

Jag har nu kollat båda datorerna utan att ha i hårddisken och även den anda datorn startar från systemskivan.

 

Kan de ha drabbats av samma problem är frågan – Båda utsattes av strömskurar på elnätet,

den 1:a med eluttaget som en dåligt iskruvad skruv orsakade och den andra av flera elstötar

på grund av fel på ennätet.

Link to comment
Share on other sites

marcushedenstrom

Shift + ö.

 

I Open firmware är tangentbordslayouten amerikansk.

Link to comment
Share on other sites

Det händer ingenting då jag har hårddisken och systemskivan i och skriver in boot cd: och klickar på return.

 

Det kommer visserligen upp en text att datorn inte kan öppna CD:n

Link to comment
Share on other sites

Det händer ingenting då jag har hårddisken och systemskivan i och skriver in boot cd: och klickar på return.

 

Det kommer visserligen upp en text att datorn inte kan öppna CD:n

 

Jag kommer tyvärr inte ihåg hur OS 9 laddades från OF, kanske det var boot cd:,\\:tbxi (med cd:n i enheten).

Jag ber om ursäkt, Har blivit ganska rosslig på både Forth och Open Firmware.

Link to comment
Share on other sites

Jag kommer tyvärr inte ihåg hur OS 9 laddades från OF, kanske det var boot cd:,\\:tbxi (med cd:n i enheten).

Jag ber om ursäkt, Har blivit ganska rosslig på både Forth och Open Firmware.

 

Jag lyckas inte skriva det bakåtlutande sned-sträcket, vet inte hur man gör det i detta läge.

Jag skrev i alla fall boot cd: och då kom en lång text av olika slag, där bl. a. sägs att den inte hittar CD:n.

 

Jag tror nog att jag vågar beställa en ny hårddisk i den sista datorn som gick sönder,

för den måste ha varit trasig, eftersom den inte syntes på skärmen, första gången

jag lyckades komma in med hjälp av systemskivan.

Då jag satte in den andra hårtddisken så kom den upp på skärmen plus att jag kunde

använda den tills jag stängdes av men inte då jag på nytt startade datorn.

 

Om jag beställer en ny hårddisk och den fungerar, vågar jag då testa den i den första datorn,

utan risk att den kan gå sönder?

 

Jag testade med att skriv det bakåtlutande snedsträcket på det vanliga sättet och då blev det

fart på CD:n, men ingen bild laddades upp, utan ett meddelande om att denna text inte var rätt.

Link to comment
Share on other sites

Macar kan krångla rejält om de små litumbatterierna har tappat musten.

 

Dt är ett nytt batteri och jag har mätt det för säkerhets skull.

Link to comment
Share on other sites

Om jag beställer en ny hårddisk och den fungerar, vågar jag då testa den i den första datorn,

utan risk att den kan gå sönder?

Tror ärligt talat inte att en ny hårddisk hjälper - det är i alla fall en ganska stor chansning på en så gammal dator…
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...