Jump to content
Just nu i M3-nätverket

lägga till en flashfil i dreamweaver?


danielpedersen

Recommended Posts

danielpedersen

Hej, jag är väldigt grön på det här med hemsidor,

jag försöker att lägga till en .swf fil i min index sida i dreamweaver,

jag har har lagt flashfilen i ett AP Div, på förhandsvisning funkar den utmärkt, men när jag sen laddar upp dessa kommer endast indexfilen upp (alltså helt tom ruta..)

Jag använder mig av CS3, Actionscript2.0

Några förslag, för ag har helt slut på dem, och det mest störiga är att jag lyckats lägga upp min gamla sida på detta vis, men jag kommer ej ihåg hur jag gjorde..

 

Tack på förhand.

Link to comment
Share on other sites

Det finns en röd ikon för Flash, där uppe du väljer tabellet mm.

 

Tryck på pilen där och välj Flash. Sedan letar du upp flash filen och väljer den, så ska det nog fungera. Annars kan du lägga upp koden här, kan ju vara något fel i kodningen också.

Link to comment
Share on other sites

hmm, röd pil?? bifogar en skärmdump

 

Du har en gammal version av DW. Själv har jag Studio 8, så jag vet inte hur den gamla fungerar.

 

Men flash-filen ligger ju där, så det borde väl fungera? Fungerar den när du öppnar filen i datorn?

Link to comment
Share on other sites

Om du tittar högst upp på tabbarna där du valt "Text" så titta på Common el Layout-tabben el Insert och se om du hittar en röd Flash-ikonknapp, kanhända att du får rulla lite i flervalsmenyer men det ska finnas där nånstans.

Alternativet är att när du exporterat flashfilen från Flash så brukar den exportera filen plus en html-sida med filen i, den html-sidans kod kan du bara slänga ner i dreamweavers övre kodfönster.

Link to comment
Share on other sites

danielpedersen

ok, flashfilen funkar perfekt i datorn, men inte när jag laddat upp den

jag löste det innan genom att endast länka indexfilen till swf filen, men då är inte flashfilmens storlek fast, och upplösningen blir inte bra..

nu är jag med på vad ni menar med röd flash knapp (det var så det såg ut innan cs3, ser inte ut så i 3:an, men jag har ju lagt in min flashfil i dreamweaver och den funkar i previewen, men varför funkar den inte live?

Link to comment
Share on other sites

Du laddade upp både nya html-filen och nya swf-filen? Och reloadade sidan i webläsaren?

Om man laddat upp en ny flashfil och tittar på den vill inte webläsaren alltid se den nya filen så man måste backa en sida och tömma webläsarens cache för att den ska ladda den nya filen, kanske kan va det?

Link to comment
Share on other sites

ok, flashfilen funkar perfekt i datorn, men inte när jag laddat upp den

jag löste det innan genom att endast länka indexfilen till swf filen, men då är inte flashfilmens storlek fast, och upplösningen blir inte bra..

nu är jag med på vad ni menar med röd flash knapp (det var så det såg ut innan cs3, ser inte ut så i 3:an, men jag har ju lagt in min flashfil i dreamweaver och den funkar i previewen, men varför funkar den inte live?

 

Har du testat att lägga höjd och bredd på den då? Alltså height="xx" och width="xx"

Link to comment
Share on other sites

danielpedersen

hej igen, tack för alla svar, men problemet kvarstår..

jag har DW 9, har kollat runt lite, och det verkar som att jag måste ladda upp en AC_RunActiveContent.js fil som automatiskt skapas i DM, men lägger sig i egen mapp i min root mapp.

Jag har flyttat denna fil till där jag har min index & swf fil, samt laddat upp alla 3, men det är fortfarande inga spår av swf filen...

några tips (jag har hört att det skall vara någon slags specialare i 9:an?)

 

tacksam för svar

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...