Jump to content
Just nu i M3-nätverket

åäö som blir skräp hos mottagaren när man skickar med Apple Mail


jonte

Recommended Posts

Är det nån som hittat någon slutlig lösning på det eviga problemet att Apple Mail skickar mail som inte går att läsa av outlook på windows ibland?

 

Att klistra in rader i terminalen som ändrar förvald textkodning verkar ju inte lösa problemet helt.

 

Problemet, för den som inte hängt med, är att Apple Mail har olika textkodningar för olika delar i mailet, tex för ämnet, rent textinnehåll, html-innehåll, bilagor osv. Enligt specifikationer för hur mailprotokollet ska se ut är detta helt ok, men Outlook för Windows tycker inte det är ok.

Link to comment
Share on other sites

problemet ligger i andra änden...outlook för windows klarar inte av att tolka koden korrekt per default.

 

kan vara lite jobbigt att be alla windowsanvändare ställa in rätt inställningar i sitt program dock....slutgiltiga lösningen (innan folk gått över till apple eller microsoft börjar göra fungerande mjukvara) vet jag inte om det finns någon.

Link to comment
Share on other sites

problemet ligger i andra änden...outlook för windows klarar inte av att tolka koden korrekt per default.

 

kan vara lite jobbigt att be alla windowsanvändare ställa in rätt inställningar i sitt program dock....slutgiltiga lösningen (innan folk gått över till apple eller microsoft börjar göra fungerande mjukvara) vet jag inte om det finns någon.

 

Men vad är rätt inställningar?

Link to comment
Share on other sites

Jag har träffat på detta problem flera gånger, främst på jobbet, där mottagare ofta sitter på Outlook. Jag väljer Brev / Textkodning / välj "Västerländsk (ISO Latin 1)". Det har funkat prima varje gång för min del...

Link to comment
Share on other sites

Seriöst, det här är ett jättevanligt problem, och ingen har koll på en lösning? Finns det ingen lösning alls? Om det är så har ju Apple stora stora problem...

Link to comment
Share on other sites

Har bara haft problem en gång och det var när jag skickade en bilaga och kryssade i att den skulle vara windows-kompatibel. Mottagaren svarade då och menade att jag hade problem med å ä och ö. Det var rena kinesiskan i det brev som han svarade med, dvs det som jag skickat honom och sen fick tillbaks. Jag provade därför att låta bli att kryssa i windowskompatibel bilaga och då fick han ett normalt brev.

Link to comment
Share on other sites

Nu har jag hört talas om en lösning som ska fungera varje gång. Skapa en signatur, och lägg dit ett Unicode-tecken och sätt vit textfärg. Det tvingar programmet att välja UTF-8 varje gång.

 

Ska testa detta.

Link to comment
Share on other sites

  • 2 weeks later...

Tyvärr är det så att Microsoft Outlook ballar ur om man använder olika teckensystem i samma brev. Även Microsofts webbpost Hotmail ballar ur. Däremot så fungerar Yahoo Mail utmärkt... Detta är alltså inget Apple-problem, utan detta är ett Microsoft-problem. Microsofts e-postklient är helt enkelt inte tillräckligt bra. Sedan så kan det förekomma att många sitter med gamla nätverk med äldre e-postklienter och e-postservrar för Windows som inte klarar *standarden* UTF-8 (som är det som Apple Mail helst vill använda).

 

Eftersom Apple Mail är ett så suveränt och överlägset mailprogram så får vi helt enkelt använda lösningar för att kompensera för Microsofts brister.

 

En sådan lösning är att under "Arkiv" - "Inställningar" - "Skriva" välja "Ren text" som textformat. Inte formaterad text (HTML). Då blandas inte olika teckensystem i samma brev längre. Detta fungerar mot senare Outlook som har stöd för UTF-8. Det är så här som jag kör.

 

Om mottagaren använder en äldre klient utan UTF-8, ja då får man köra på ISO Latin 1 eller Windows Latin I, som man väljer i "Brev" - "Teckenkodning".

 

Vi får hoppas att Microsoft uppgraderar sina e-postklienter till mer modern standard så att vi Macare slipper kompensera för att Microsoft ligger efter i utvecklingen.

 

Hälsar

R

Link to comment
Share on other sites

Tyvärr är det så att Microsoft Outlook ballar ur om man använder olika teckensystem i samma brev. Även Microsofts webbpost Hotmail ballar ur. Däremot så fungerar Yahoo Mail utmärkt... Detta är alltså inget Apple-problem, utan detta är ett Microsoft-problem. Microsofts e-postklient är helt enkelt inte tillräckligt bra. Sedan så kan det förekomma att många sitter med gamla nätverk med äldre e-postklienter och e-postservrar för Windows som inte klarar *standarden* UTF-8 (som är det som Apple Mail helst vill använda).

 

Eftersom Apple Mail är ett så suveränt och överlägset mailprogram så får vi helt enkelt använda lösningar för att kompensera för Microsofts brister.

 

En sådan lösning är att under "Arkiv" - "Inställningar" - "Skriva" välja "Ren text" som textformat. Inte formaterad text (HTML). Då blandas inte olika teckensystem i samma brev längre. Detta fungerar mot senare Outlook som har stöd för UTF-8. Det är så här som jag kör.

 

Om mottagaren använder en äldre klient utan UTF-8, ja då får man köra på ISO Latin 1 eller Windows Latin I, som man väljer i "Brev" - "Teckenkodning".

 

Vi får hoppas att Microsoft uppgraderar sina e-postklienter till mer modern standard så att vi Macare slipper kompensera för att Microsoft ligger efter i utvecklingen.

 

Hälsar

R

 

Visst stämmer det att det är Microsoft som inte följer den fastslagna standarden, men Apple Mail är det enda mailprogram som beter sig på detta sättet, och när de vet om att det är ett stort problem så ska de rätta sig i ledet, punkt. Både Apple och Microsoft har gjort fel, och eftersom Microsoft vägrar göra något åt det så måste Apple göra det för att inte kunderna ska hamna i kläm.

Link to comment
Share on other sites

Thomas Ytterberg

Jag sitter i den delikata positionen att jag skrivit om dessa problem i över tio års tid (och det var värre förr), men i princip aldrig råkat ut för det. Men då kör jag också Eudora av gammal vana och använder ISO 8859-1 (Latin1) hela tiden. Det händer att jag får felkodade brev, men de kan Eudora ofta fixa.

 

Grundförklaringen är att Apples Mail kodar brevets delar med olika teckenkodningar vilket är dumt. Sedan är det bara Outlook av de erkända programmen som har problem med detta, vilket är lika dumt. :utskallning:

 

Så lösningen ska vara att i terminalen köra...

 

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

 

...så att breven alltid kodas i unicode, UTF-8

 

Eller att bara hålla sig till ren text.

 

Sedan finns det flera av varianter på dessa lösningar som att lägga in ett dingbat-tecken i signaturen och göra den vit. Dessa bör nås via teckenpaletten.

 

Den universella lösningen är att alla konsekvent håller sig till UTF-8 för e-posten, men där är vi inte ännu. Det finns många olika program och e-postsystem igång där ute som sätter krokben för åäö.

Link to comment
Share on other sites

Både Apple och Microsoft har gjort fel, och eftersom Microsoft vägrar göra något åt det så måste Apple göra det för att inte kunderna ska hamna i kläm.

 

Eftersom Apple vägrar göra något åt det så måste Microsoft göra det för att inte kunderna ska hamna i kläm. Microsoft e-post klient och webbtjänst Hotmail är de enda som har problem med blandningen av teckensystem i samma brev. Yahoo Mail fungerar excempelvis utmärkt! Det finns många andra aktörer än Microsoft och eftersom de andra fungerar, så är detta ett Microsoft-problem och inte ett Apple-problem.

 

Jag har "Ren text" inställd i Apple Mail och detta fungerar utmärkt mot senare Outlook och även mot Hotmail. Jag får inga klagomål på åäö i Apple Mail. Gör den inställningen i Apple Mail och problemet är löst.

 

Om mottagare får problem så sitter de med en äldre e-postklient som saknar stöd för UTF-8, då får man välja ISO Latin 1 eller Windows Latin 1.

 

Hälsar

R

Link to comment
Share on other sites

Så lösningen ska vara att i terminalen köra...

 

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

 

...så att breven alltid kodas i unicode, UTF-8

 

I min Apple Mail försvinner möjligheten att välja något annat än UTF-8 om man gör så, det går alltså inte att välja Windows Latin 1 eller ISO Latin 1 för de mottagare som sitter med äldre e-postklienter / äldre system. Därför rekommenderar jag att man kör Ren text, för då blir det UTF-8 rakt igenom om man har Apple Mail ställd på Automatisk, och man kan fortfarande välja ISO Latin 1 eller Windows Latin 1 för de mottagare med äldre lösningar.

 

Hälsar

R

Link to comment
Share on other sites

Thomas Ytterberg

Bra inlägg här! Frågan diskuteras ofta. Det är tyst i ett par månader sedan är det en hoper frågor på en gång. Så jag prövar att "Nita tråden" som det heter. :)

 

Här är en ofta refererad sida om problemet och lösningarna, som dock inte tycks fungera för alla.

Link to comment
Share on other sites

Jag har varit med och tjatat i detta ämne ett tag, men är det någon som vet om det är fixat i leopard?

Kör leopard sen det kom ut då jag provade att gå tillbaka från entourage till mail, men då fick mottagarna problem med mina bifogade filer (har ej haft det förut)

Link to comment
Share on other sites

Jag har varit med och tjatat i detta ämne ett tag, men är det någon som vet om det är fixat i leopard?

Kör leopard sen det kom ut då jag provade att gå tillbaka från entourage till mail, men då fick mottagarna problem med mina bifogade filer (har ej haft det förut)

 

Bifogade filer är väl något annat än åäö-problematiken. Se bara till att kryssa i "skicka Windows-kompatibla bilagor" så ska det inte vara några problem med de bifogade filerna.

Link to comment
Share on other sites

Jag har varit med och tjatat i detta ämne ett tag, men är det någon som vet om det är fixat i leopard?

Kör leopard sen det kom ut då jag provade att gå tillbaka från entourage till mail, men då fick mottagarna problem med mina bifogade filer (har ej haft det förut)

 

Nej, jag vet inte om Leopard fixar buggen i Outlook som gör att Outlook inte klarar flera teckensystem i samma brev - något som flera andra e-postklienter klarar utan de problem som Outlook uppvisar.

 

Skippa Rich-Text och kör Ren text istället. Då blir det samma teckenkodning genomgående i brevet och då tappar inte e-postklienten bort bilagorna - under förutsättning att "Skicka Windows-kompatibelt" är förbockat i filfönstret.

 

Om dina mottagare använder gamla e-postklienter eller sitter i nätverk med äldre e-postservrar (exempelvis sitter med Windows NT) som inte klarar den aktuella standarden UTF-8 så får du skicka med den utgågna standarden ISO Latin 1, eller Microsofts gamla Windows Latin 1.

 

Hälsar

R

Link to comment
Share on other sites

Bifogade filer är väl något annat än åäö-problematiken.

 

Nja, de hör faktiskt ihop. Om Outlook ballar ur på grund av teckenkodningen så kan den missa bifogade dokument.

 

Hälsar

R

Link to comment
Share on other sites

Jag sitter i den delikata positionen att jag skrivit om dessa problem i över tio års tid (och det var värre förr), men i princip aldrig råkat ut för det. Men då kör jag också Eudora av gammal vana och använder ISO 8859-1 (Latin1) hela tiden. Det händer att jag får felkodade brev, men de kan Eudora ofta fixa.

 

Grundförklaringen är att Apples Mail kodar brevets delar med olika teckenkodningar vilket är dumt. Sedan är det bara Outlook av de erkända programmen som har problem med detta, vilket är lika dumt. :utskallning:

 

Så lösningen ska vara att i terminalen köra...

 

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

 

...så att breven alltid kodas i unicode, UTF-8

 

Eller att bara hålla sig till ren text.

 

Sedan finns det flera av varianter på dessa lösningar som att lägga in ett dingbat-tecken i signaturen och göra den vit. Dessa bör nås via teckenpaletten.

 

Den universella lösningen är att alla konsekvent håller sig till UTF-8 för e-posten, men där är vi inte ännu. Det finns många olika program och e-postsystem igång där ute som sätter krokben för åäö.

 

Varianten med

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

har visat sig inte fungera hos en flera avsändare. Av någon anledning fungerar det med unicode-tecken i signaturen bättre... Märkligt.

 

Eftersom Apple vägrar göra något åt det så måste Microsoft göra det för att inte kunderna ska hamna i kläm. Microsoft e-post klient och webbtjänst Hotmail är de enda som har problem med blandningen av teckensystem i samma brev. Yahoo Mail fungerar excempelvis utmärkt! Det finns många andra aktörer än Microsoft och eftersom de andra fungerar, så är detta ett Microsoft-problem och inte ett Apple-problem.

 

Ja fast när du mailar med kunder och leverantörer hela dagarna kan du inte skylla på att "det är din mail som har problem" - de har ju bara problem med mig.

Microsoft skiter väl i om något enstaka mail från Apples mailprogram inte fungerar. De tycker säkert bara det är bra, för det spär på allmänna uppfattningen om att Mac är inkompatibel.

Link to comment
Share on other sites

Jag är fullständigt övertygad om att det är en medveten strategi från Microsoft att Outlook brister i hanteringen av teckenkoder, därför att då kan de alltid säga "Det hade aldrig hänt om avsändaren körde Microsoft". De utnyttjar sin stora ställning, som de har visat så många gånger förr. (Internet Explorer är ett typexempel på en mjukvara som inte helt följer standarden, och då har många hemsidor anpassats speciellt för IE vilket får till följd att icke-IE browser - som följer den officiella standarden - visar sidorna annorlunda).

 

Hälsar

R

Link to comment
Share on other sites

Skit samma att det är Microsofts problem. Hur svårt kan det vara för Apple att fixa detta? Funker jo for fn på Entourage. :angry2:

Link to comment
Share on other sites

Nu har jag hört talas om en lösning som ska fungera varje gång. Skapa en signatur, och lägg dit ett Unicode-tecken och sätt vit textfärg. Det tvingar programmet att välja UTF-8 varje gång.

 

Ska testa detta.

 

Jag har också problem med åäö. En del som kör Outlook Express verkar få problemet. Tänkte därför prova ovanstående metod. Hur lägger jag enklast dit ett Unicode-tecken?

Sedan är frågan också vilket Charset som bör vara default? Jag har tidigare kört tidigare nämnda terminalkommando och ställt in UTF-8 men en del mottagare får fortfarande problem. Vilket Charset bör alltså vara inställt när man använder Unicode-tecken i signaturen?

Link to comment
Share on other sites

För mig verkar det funka om jag skriver "nytt" mail till PC men inte om jag "svarar" då blir det konstiga tecken".

 

Är det nåt som hindrar /är till nackdel med att ha "Windows Latin 1" eller "ISO Latin" inställt hela tiden/alltid ?

Link to comment
Share on other sites

Har också problem med det här av och till. Det verkar ju inte bara vara åäö, utan det är som om den rycker stavelser ur orden lite här och där och gör om dem till kinesiska tecken

 

Skulle vara intressant om någon med överblick över hela situationen kunde ta ett samlat grepp och försöka förklara för oss som inte hajar allt.

 

Vad är ett unicode-tecken t ex?

 

Kunde inte macworld ta upp det här och göra en ordentlig test på vad som funkar och vad som inte gör det?

 

En macig manual helt enkelt, från grunden?

Link to comment
Share on other sites

Skit samma att det är Microsofts problem. Hur svårt kan det vara för Apple att fixa detta? Funker jo for fn på Entourage. :angry2:

 

Att introducera Microsoft-buggar i Apples mjukvara tycker jag inte är att "fixa" något.

Apple följer internationell standard, det är Microsoft som inte gör det.

 

Välj "Ren text" istället för "Formaterad" i Apple Mails inställning för Skriv, så löser det problemen.

 

Hälsar

R

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...