Jump to content
Just nu i M3-nätverket

Lägga till $PATH ?


jakob.bohem

Recommended Posts

Jag försöker att lägga till en mapp till min $PATH, men kommandot jag försöker använda fungerar inte, vet nån hur det ska se ut egentligen?

PATH = $PATH\:/min/path; export PATH

Den säger "command not found"...

 

ED: Om jag skriver:

$PATH = $PATH\:/min/path

säger den "no such file or directory", jag måste ha missat nåt..

Link to comment
Share on other sites

marcushedenstrom

Jag lägger allt sånt i filen ~/.profile.

 

export PATH=/apa/:$PATH

skriver jag i den, till exempel.

Link to comment
Share on other sites

Vet du om du använder bash eller tcsh?

 

I tcsh skriver du:

setenv PATH $PATH\:/min/path[/codeBOX]

 

I bash skriver du:

[codeBOX]PATH=$PATH:/min/path[/codeBOX]

 

Alltså utan blanktecken runt =

Link to comment
Share on other sites

Jag försöker att lägga till en mapp till min $PATH, men kommandot jag försöker använda fungerar inte, vet nån hur det ska se ut egentligen?

PATH = $PATH\:/min/path; export PATH

Den säger "command not found"...

 

ED: Om jag skriver:

$PATH = $PATH\:/min/path

säger den "no such file or directory", jag måste ha missat nåt..

 

Precis som Olamontan säger, angående "använder du tcsh eller bash?", så är det uppenbart att du råkat ut för ett ganska pinsamt problem (troligen många fler Mac OS X Jaguar/Panther-användare, etc, än du som inte upptäckt skillnaden). Du har tydligen kört en tidigare OS X-utgåva innan och scriptat där. I Tiger bytte Apple tcsh mot bash, vilket knappast någon större mängd Mac-användare märkt av eller ens känner till :D. Men så är det iaf. Eftersom att jag ser att du kör en Powerbook G4 och säkert har UNIX-scriptat i Mac OS X Panther tidigare med tcsh som standard shell, så förstår jag din förvirring. Har jag rätt? :)

 

Det korrekta sättet att lägga till innehåll i PATH-miljövariabeln är precis som blivit påpekat:

PATH=$PATH:/min/path

Punkt slut. Så ser det ut när man kör Mac OS X Tiger och alla nästkommande derivativ. Anledningen till att den säger "No such command" när du kör $PATH = $PATH, osv, är för att den försöker exekvera den binär som den TROR finns definierad i $PATH-variabeln du angav. Det går t.ex. att göra så här:

 

GAME="/usr/bin/mygame"

$GAME --fullscreen --joystick="enabled"

det är detsamma som att köra /usr/bin/mygame -- fullscreen --joystick="enabled"

 

Ett typo på commandline bland miljövariabler kan ge galna bieffekter, så det gäller att ha ögonen öppna. Men tro mig att man kan sitta i timmar och inte fatta vad som är fel med ens script pga en bakvänd slash eller en parentes för mycket eller lite. Ett tips är att editera shellscript med en editor som pallar syntax hilighting på det du skriver, t ex svenskutvecklade Smultron (http://smultron.sf.net)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...