Just nu i M3-nätverket
Gå till innehåll
TB-000

LÖST Felsöka långsam TimeMachine backup till NAS

Rekommendera Poster

TB-000

Jag kör TimeMachine backup till en QNAP HS-251+ NAS med 2 st (speglade, RAID-1) mekaniska hårddiskar (WD60EFRX) över gigabit ethernet.

Det har fungerat bra men senaste 2–3 månaderna har jag märkt att det har blivit långsamt. Jag kör nu macOS 10.15.6, men problemet fanns också i 10.15.5 (kanske även i tidigare versioner.)

 

TimeMachine kopieringen som ska ske varje timme till NAS tar nu oftast 2 – 3 timmar (normalt c:a 100 – 200 MB enligt TimeMachines statusinformation).

Samma problem med både iMac 2015 och MBP 2015 mot denna NAS. (Samma problem även när bara en mac är igång.)

 

När jag går in i QNAPs web-interface ser allt bra ut:

  • C:a 70 % ledigt utrymme på partitionen för TimeMachine. 
  • CPU-användning i NASen ligger på 2 – 4 %
  • Disk-test utförd och hittar inga fel.
  • SMART status OK. 
  • Alla indikatorer jag hittar är gröna/OK.

 

Några idéer om hur man felsöker detta? 

Jag vet ju inte om felet är i NASen eller i Mac.

 

(Jag är osäker om det här är rätt avdelning på forumet för den här typens fråga, men jag hittade ingen avdelning jag tyckte passade bättre.)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Telly82

Kan ju vara din router eller dina nätverkskablar. Stäng av routern, koppla ur och i nätverkskablarna (för att ta bort eventuell oxid på kontakterna) och sätt igång routern igen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
TB-000
Postad (redigerade)
12 minuter sedan, Telly82 säger:

Kan ju vara din router eller dina nätverkskablar. Stäng av routern, koppla ur och i nätverkskablarna (för att ta bort eventuell oxid på kontakterna) och sätt igång routern igen.

Jag har felsökt där utan att hitta några problem.

 

Jag testade nu också att kopiera en 1 GB stor m4v-fil från media-partionen på samma NAS (annan partition på samma speglade diskar) till min iMac och tillbaka till NASen under nytt namn. Båda kopieringarna gick på 10 sekunder d.v.s. nära 1 gigabit/s. (Märkligt, då verkar ju NAS, nätverk och hårddiskar fungera OK. Varför är då TimeMachine så långsam mot denna NAS?)

 

 

Redigerad av TB-000

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
TB-000
Postad (redigerade)

Jag ska kanske tillägga informationen att:

 

Hela tiden en TimeMachine backup kör (alltså i timmar för 100 – 200 MB) hör man hur NASens hårddiskar febrilt flyttar läs/skrivhuvudena. Låter som 5 – 10 förflyttningar per sekund i timmar för att skriva 100 – 200 MB. (Ja, jag vet att det är många "hard links" i en TimeMachine backup, men ändå).

 

Om jag kopierar ett stort katalogträd till en annan partition på NASen så hörs också ljud från läs/skrivhuvuden, men med mycket lägre frekvens. Låter som c:a en förflyttning per sekund i en minut för att skriva ett katalogträd på 6 GB.

 

Jag får en känsla av att TimeMachine i kombination med QNAP på något vis har lyckats lägga data på hårddiskarna så att läs/skrivhuvudet måste flyttas enormt ofta när en backup görs. – Om det är så, varför är det ett problem nu när det inte var det ifjol?

 

Vid sökning på internet så hittade jag information från 2010 om att Spotlight-indexering gör TimeMachine-backup till QNAP långsammare. Jag testade att följa instruktionerna att undanta backupen från Spotlight-indexering, men det gjorde ingen skillnad.

 

55 minuter sedan, Stab säger:

Hej, 

denna artikel kanske kan hjälpa dej att snabba upp time machine backupen:

 

https://www.mackungfu.org/massively-speed-up-time-capsule-time-machine-backups

Att justera prioriteten som Stab föreslår gör inte heller någon skillnad – det är inte där flaskhalsen är i det här fallet.

 

Redigerad av TB-000

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
TB-000
Postad (redigerade)

Jag hade satt upp QNAP så att den tillhandahöll Backup Server / Time Machine enligt denna enkla inställning. Det resulterade i att alla (i mitt fall båda) Macarna som kör TimeMachine mot NASen gjorde det som samma NAS-användare och till samma NAS-volym.

 

När jag felsökte den långsamma backup-kopieringen så upptäckte jag att även MBPs .backupbundle ändrades när jag körde TimeMachine-backup på iMac och MBP var avstängd. Mitt intryck är alltså att TimeMachine-QNAP-kombinationen på något vis blandade ihop vilka filer som hörde till backup från vilken dator eller lagrade filer till båda datorerna blandat i båda .backupbundle.

 

Jag hittade denna beskrivning av "Backing up one or more Macs using different NAS user accounts". Jag satte upp två separata volymer (=partitioner) på QNAP, och två separata användare på QNAP som delade ut en volym var till varsin mac. På det viset tycker jag att TimeMachine-backup-data måste hållas åtskilt för mina två mac. 

 

När jag flyttade iMacs .backupbundle till en volym och MBPs .backupbundle till en annan volym och sedan körde TimeMachine mot dem för att fortsätta så tyckte TimeMachine på mac att de var trasiga och att den måste börja på en ny initial-backup. 

 

Med den här uppställningen så gick initialbackup på 2 – 4 timmar, d.v.s. ungefär samma tid som det tidigare tog att göra en inkrementell backup på 100 – 200 MB. 

 

Just nu verkar det som att jag löst problemet med långsamma TimeMachine-säkerhetskopieringar till QNAP NAS. Vi får se om ett år om det håller eller om även dessa TimeMachine-säkerhetskopior blir långsamma med tiden.

 

Redigerad av TB-000
  • Tack 1

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...