Jump to content
Just nu i M3-nätverket

Uppgraderad MacBook pro (2010) som beter sig konstigt?


CaptainKarrow

Recommended Posts

CaptainKarrow

Hej!

Första inlägget på det här forumet. Ursäka för en novell.

 

Har en MacBook Pro 13" (mid-2010) som för drygt två veckor sedan började krångla. Från att fungera okej (men lite segt), så började Finder hänga sig och datorn blev väldigt trött och seg. Det gick knappt att tvångsavsluta och inga program ville öppnas. Det gick verkligen över en natt. Tisdag kväll funkade datorn. Onsdag kväll - nej.

 

Då körde jag Mavericks (10.9.5). 4gb RAM, 2,4ghz processor och en 256gb hårddisk.

Har rådfrågat kontakter, googlat (och även hittat hit) och började misstänka att det var min hårddisk som började ge upp.

 

Så köpte en 250gb SSD (samsung 850 Evo) och 8gb ram (Corsair).

Satte i dessa igår utan några problem alls. Startade upp med installationsskivan som jag fick med när jag köpte datorn för att först skapa en partion och sedan installera Snow Leopard 10.6.3. Installationen gick också bra tills jag skulle genomföra inställningsassistenten. Då började datorn hänga sig vid tex sista momentet ("skapa konto"). Trots att jag läst att Apple själva gett rådet att vänta sisådär 30min för att låta det slutföra om det låst sig, så hände inget. Vid omstart var det samma sak.

 

Så jag valde att börja helt om från början.

 

Installerade om OSX. Inställningsassistenten flöt på och jag kom in i datorn igen. Tjoho!

Tänkte jag.

 

Då vill den inte öppna program. Trycker jag på en ikon, tex Safari, så gör den ett kort ljud och så händer ingenting.

Sedan låser sig Finder igen och jag får den här fina men just nu väldigt irriterande snurrande "badbollen". Som innan jag bytte minnen och hårddisk.

 

Jag har inte installerat något program/uppdatering efter installationen av osx. Skivan verkar vara felfri i skivverktyget.

 

Vad tror ni är fel?

Link to comment
Share on other sites

CaptainKarrow

Jag har testat att byta tillbaka till de ursprungliga 2gb-minnena (2x2gb) och problemet verkar kvarstå.

 

Det började fint när jag startade datorn. Kunde gå in i safari och surfa runt. Sen började den att tugga med att ladda sidor och när jag öppnade en till flik så blev fönstret hel vitt och en snurrade badboll dök upp. Står så och bara tuggar. Kan inte tvångsavsluta. Det är liksom Finder som hänger sig.

Link to comment
Share on other sites

Postar en lista man kan prova sig fram med:

 

Sammanställning av åtgärder när datorn krånglar:

Säker start - lätt städning som fixar småstrul. Åtgärd No1 om Macen inte är sig lik.

Håll ner Shift under uppstart. Låt datorn jobba klart. Logga in. Starta om som vanligt.

http://support.apple.com/kb/ht1564?viewlocale=sv_SE

Återställa NVRAM - löser småbuggar gällande inställningar typ klocka

http://support.apple.com/kb/HT1379?viewlocale=sv_SE

Återställ SMC - löser problem med hårdvarukrets som sköter fläktar, av/på, batteriladdning mm

http://support.apple.com/kb/HT3964?viewlocale=sv_SE

Reparera skivbehörigheter - löser problem med filer som strular och inte vill öppnas vilket kan ge märkliga symptom. Skall utföras efter uppgradering av OS X.

Skivverktyget, hittas i Verktygsmappen i mappen Program.

OBS. Finns inte i ElCapitan och nyare OS X.

https://support.apple.com/sv-se/HT201560

Reparera skiva - lagar filträdet som OS X "hänger" på. Lagar inte mekaniska fel. Skiva i detta fallet menas inte den fysiska skivan. Skivverktyget, hittas i verktygsmappen i mappen Program. Från OS X 10.7 gäller Återställning. Se

http://support.apple.com/sv-se/HT4718

Observera att skivverktyget kan behövas köras flera gånger då den lagar i etapper om det är flera fel.

....

Not 1:

De tre första är ofarliga åtgärder. De två sista bör/ska inte göras om det inte finns backup.

Not 2:

Alla tecken på strul med datorn kan betyda att hårddisken är på väg att ge upp. Se till att ha Backup innan du gör något annat!!

Not 3:

Seg Mac kan bero på nått så enkelt som att hårddisken är överfull. Räkna med att ha minst 20 GB ledigt då OS X kräver en del utrymme för processer i det dolda som indexering och defragmentering, läsning och skrivning av tillfälliga filer/chachefiler. Mellan 20 och 10 GB ledigt är farozonen. Under 10 GB ledigt är det mest tur om den överhuvudtaget fungerar…..

Link to comment
Share on other sites

Har du testat att byta tillbaka till den gamla hårddisken? Det faktum att Finder krånglar mest tyder på fel med lagringen. Kanske din nya SSD inte fungerar (trasig, passar inte).

 

Jag har själv bytt till en SSD i min MacBook Pro 13-inch, Mid 2012 och det har fungerat klockrent.

Link to comment
Share on other sites

CaptainKarrow

Tack för svar!

 

Jag har inte testat att återställa NVRAM eller SMC. Har däremot testat att reparera disk och behörighete. Hittar inga fel.

 

Och Finder blir okontaktbar även i säkert läge.

 

Har inget installerat på den nya hårddisken, utöver osx, så det är drygt 240gb ledigt.

 

Körde även den utökade versionen Apple hardware test nyss. Inga fel.

 

 

OlaMontan:

Nä, har inte testat att byta tillbaka då jag inledningsvis trodde det var fel på hårddisken och vill inte riskera att alla mina filer försvinner... :)

 

Jag valde en ssd som fler använt till just MacBook pro 13" från 2010, så jag hoppas att den passar. :)

 

Men hmmm, om problemet skulle kvarstå även om jag byter tillbaka till den gamla hårddisken? Vad är det då som är knasigt?

 

Ska nu testa att koppla ur ssd:n och köra via USB. Hittade en tråd på Apples egna forum där någon hade liknande problem (med med MacBook från 2011 eller 2012). I det fallet var det SATA-kabeln som strulade och när den byttes så funkade det fint igen. Återkommer om resultat.

Link to comment
Share on other sites

CaptainKarrow

Nu är problemet med ssd och nya ramminnen löst, men jag kommer inte åt min gamla hårddisk.

 

Den kopplas in som en extern hårddisk och visas i Finder. Sen visas inga filer, Finder laddar lite, den försvinner den Finder men en ruta med texten "felaktig utmatning, mata ut innan du kopplar från eller stänger av".

 

Kan inte koppla ifrån disken.

 

Testar terminalen. diskutil list visar disken som disk0s2. diskutil mount /dev/disk0s2 säger att den är mountad.

 

diskutil unmount /dev/disk0s2 säger följande: "Volume Karrow on disk0s2 failed to unmount: dissented by PID=0 (kernel)"

 

Va? :(

Link to comment
Share on other sites

  • 3 months later...
Soul Sacrifice

Tjena

 

Har tyvärr ingen lösning på sistnämnda strul, men har samma problem som du hade med att program och finder hänger sig. Har testat radera hårddisken och installera om OSX men samma sak händer igen. Har försökt reparera disken också. Ska gå igenom Axelmans lista när jag har tid.

 

Hur fick du nya disken att funka?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...