MacWorld forum Just nu i M3-nätverket
Jump to content
TommyS

Med Sierra funkar inte NASen som den ska längre

Recommended Posts

Sedan uppgraderingen till Sierra häromveckan så strular det hos mig.
Min NAS tappar på något sätt numera kontakten.

I meningen att den försvinner från Finder.

Tittar jag i programmet för NASen så är det stabilt, därifrån försvinner den inte.

Å högerklickar jag på Finder och väljer Anslut till server så är det inga problem att återfå kontakten.

 

Det här problemet existerade inte innan jag gick över till Sierra.

 

Senaste mjukvaran i NAS och Fildelning är inställd med AFP aktiverad.

 

Hmm... spontan känsla säger, skulle inte nappat på att att gå över till Sierra...

 

Har alltså inte gjort några andra ändringar vad gäller programinstallation eller ny router el dyl.

?

 

Betyder konkret t ex att det är helt lönlöst att köra Bilder nu. Varje gång programmet startas så måste biblioteket Repareras. Å om jag lyckas få det reparerat så hjälper det inte att lämna det så utan i sinom tid så kommer meddelande om att Bilder måste avslutas (biblioteksproblem).

Edited by TommyS

Share this post


Link to post
Share on other sites

Provat SMB istället för AFP?

Ska testa nu.

 

Men är det inte precis tvärtom... att det är AFP som är bäst för Mac?

 

... Eller skulle då övergången till Sierra påverka detta, tänker du?

Share this post


Link to post
Share on other sites

Apple har mer eller mindre gett upp AFP men det är mycket möjligt att de har varit inne och pillat på det i och med Sierra.

Ärligt talat har jag ingen aning om vad som felar men man måste någonstans börja testa.

Share this post


Link to post
Share on other sites

Har nu testat med allt det som jag kan komma på och dessutom ett flertal ggr.


Inte minst då Reparera bibliotek, vilket ibland har lyckats - men sen har jag hamnat i läge där det inte funkar igen, å ibland funkar det inte att Reparera heller.

Rabblar inte upp alla möjliga felmeddelande jag fått här (bifogar några skärmdumpar i stället) och slutsatsen måste till 100 vara att NASen och iMacen och/eller nätverket inte längre funkar tillsammans.

Å strulet började alltså efter att jag uppgraderade till Sierra!


Vis av tidigare erfarenheter då husets HP-skrivare/scanner länge inte funkade med en iOS-uppgradering så valde och tvekade jag länge på att gå på Sierra men så här många månader efter lansering så trodde jag att man skulle kunna känna sig trygg... Idag skulle jag aldrig välja att göra det - och kommer dessutom att vara än mer skeptisk i framtiden.

Förhoppningsvis finns det en lösning som någon vänlig och kunnig själ kan leverera mig för jag är för okunnig kring tekniken och i kombination med att det då tar extra lång tid att googla och hålla på att försöka förstå så är det bara blä...

Sånt här skall bara funka! Å det har det alltså gjort också.

Enda jag kan komma på är om man på något sätt kan låsa "IP-adress" eller dylikt??

Har testat att ändra från AFP till SMB i NASen, samt även haft både dem aktiverade. Fick det att funka med bara SMB ett tag och trodde att Lösningen var här... men icke, det strulade snart igen.

Den oftast förekommande anledningen (?) är att NASens båda volymer försvinner från Finder vad gäller de diskar jag ser under Enheter. NASen syns däremot hela tiden under Delat.

Ser att det finns något som heter DLNA ("status inaktiverad") i min NAS inställningar... Kan det vara något...? (Inget jag ändrat på sen Sierra... men halmstrå?)

PastedGraphic-2.tiff

PastedGraphic-3.tiff

PastedGraphic-4.tiff

PastedGraphic-5.tiff

PastedGraphic-6.tiff

Share this post


Link to post
Share on other sites

Apple har mer eller mindre gett upp AFP men det är mycket möjligt att de har varit inne och pillat på det i och med Sierra.

Ärligt talat har jag ingen aning om vad som felar men man måste någonstans börja testa.

 

Detalj... När jag klickar på Anslut till server (via högerklick på Finderikonen) så får jag per default fram en serveradress som inleds med afp.

Detta även när jag ändrar från AFP till SMB i NASens inställningar.

 

Känns för mig som lite väl slumpartat, att den bokstavskombinationen (afp) dyker upp där... Eller har det ingen betydelse i sammanhanget?

PastedGraphic-7.tiff

Edited by TommyS

Share this post


Link to post
Share on other sites

Lägg inte upp tiff-filer utan det måste vara jpeg eller png filer.

Har ingen lust att ladda ner några filer för att se bilderna.

Share this post


Link to post
Share on other sites

Håller med och förstår dig!

 

Dessvärre lyckades jag inte bifoga i JPG-format, fick felmeddelande då - och nu när jag testar också...

 

Fel Denna uppladdning misslyckades

Å då gjorde jag bara Amatör-ändringen av formatet på skärmdumparna... genom att ändra filnamnet till .jpg i stället för .tiff...

Vilket säkert kan vara förklaringen!

Men jag vet inte hur jag gör annars, för att konvertera...??

 

Dessutom skulle jag nu och för all evighet vilja ändra så att skärmdumpar per default alltid blir i jpg-format!

Hur gör man det måntro?

Share this post


Link to post
Share on other sites

Dessutom skulle jag nu och för all evighet vilja ändra så att skärmdumpar per default alltid blir i jpg-format!

Hur gör man det måntro?

Öppna Terminal och kör:

defaults write com.apple.screencapture type -string png;
killall SystemUIServer;

Du kan välja mellan: png, jpg, gif, tiff, bmp.

“png” är ett lossless-format, precis som tiff så det är bra. “jpg” är ett komprimerat format. Ger något sämre kvalitet, men mindre filer också. Skall man göra stora skärmdumpar och posta på forumet är jpg att föredra.

Ta en rad i taget... enter efter varje. :crossfingers::yeahbaby:

 

- - -

 

En liten crash-course till resten: :)

 

Det finns fler saker du kan ändra den vägen.

# Typ (som ovan): png, jpg, gif, tiff, bmp
defaults write com.apple.screencapture type -string png;

# Namn/prefix (istället för Skärmavbildning_*)
defaults write com.apple.screencapture name -string Bild;

# Fönsterskugga, när man är i fönsterläget
defaults write com.apple.screencapture disable-shadow -bool true;

# Plats... Var bilderna skall sparas. Man
# kanske vill ha en egen folder för dem.
defaults write com.apple.screencapture location -string /path/to/folder;

# Exempel: en egen folder i bildfoldern, kör:
mkdir ~/Pictures/__dumpar;
defaults write com.apple.screencapture location -string "~/Pictures/__dumpar";

# Avsluta alltid med:
killall SystemUIServer;

 

För att läsa innehållet kan du köra:

defaults read com.apple.screencapture

För att läsa en enskild kan du köra:

defaults read com.apple.screencapture type

 

För att ta bort en, och återgår till det förvalda värdet:

defaults delete com.apple.screencapture type
Edited by iEricF
la till radnummer i de 2 första kodblocken

Share this post


Link to post
Share on other sites

Men jag vet inte hur jag gör annars, för att konvertera...??

Ett enkelt sätt är att öppna bilden i Förhandsvisning, och sen i menyn välja att Exportera. Där kan du välja ett annat format sen.

 

post-64246-0-73062700-1490049420.png

 

post-64246-0-29313800-1490049424.png

Share this post


Link to post
Share on other sites

 

Öppna Terminal och kör:

defaults write com.apple.screencapture type -string png;
killall SystemUIServer;

Ta en rad i taget... enter efter varje. :crossfingers::yeahbaby:

 

- - -

 

Tack för alla dessa tips! Skall se vad jag har nytta för.

 

Bara så att jag inte missuppfattar...

Hur många Enter menar du ovan? (För mig är allt från defaults till png; 1 rad.

 

Å när jag öppnar Terminal nu (har nog aldrig varit där förut) så står markören intill ett dollartecken (som föregås av mitt efternamn).

Skall jag först klicka Enter där då - så att markören då (?) hoppar ner till ny rad?

 

 

Edited by TommyS

Share this post


Link to post
Share on other sites

Bara så att jag inte missuppfattar...

Hur många Enter menar du ovan? (För mig är allt från defaults till png; 1 rad.

Yep... :yeahbaby:

 

Skrev även med några semikolon där, ifall du skulle råka kopiera fler rader på en gång.

 

Å när jag öppnar Terminal nu (har nog aldrig varit där förut) så står markören intill ett dollartecken (som föregås av mitt efternamn).

Skall jag först klicka Enter där då - så att markören då (?) hoppar ner till ny rad?

Ja, det är alltid lite text i början av varje rad. Namn och sånt - och så avslutar det med $ (och en osynligt mellanslag).

 

Kör du t ex en så ser det ut så här sen i Terminal:

text text ~$ defaults write com.apple.screencapture type -string png;
text text ~$

Så kör man nästa...

text text ~$ defaults write com.apple.screencapture type -string png;
text text ~$ killall SystemUIServer;
text text ~$

Jag skall fixa inlägget ovan med radnummer, så blir det enklare att se ifall forumet bryter raderna över fler raden.

Share this post


Link to post
Share on other sites

Yep... :yeahbaby:

 

Skrev även med några semikolon där, ifall du skulle råka kopiera fler rader på en gång.

 

Ja, det är alltid lite text i början av varje rad. Namn och sånt - och så avslutar det med $ (och en osynligt mellanslag).

 

 

OK, seems goody. Skall testa, innan jag lägger in skärmdumpar i forumet nästa gång.

 

Om vi går tillbaka till problemställningen i tråden så är läget i skrivande stund - vad det verkar - isolerat till min systembiblioteksfil i Bilder.

Alltså familjens bildbibliotek. (Som vi just nu alltså inte alls kan nå.)

 

Sen jag ändrade från AFP till SMB2 så har inte längre NASens båda volymer tappat kontakten i Finder.

Känns alltså som att mycket talar för att just den åtgärden var rätt.

 

Men jag får nu ändå inte Bilder att funka alltså.

Sannolikt är det ju något som hänt i alla försöken att få NASen att connecta som den ska efter övergången till Sierra, som stökat till det.

 

Jag har provat många ggr de senaste dagarna, att via Bilder-kommandot Reparera få det att funka.

Men de senaste gångerna stannar processen upp efter ett par timmars tuggande med följande felmeddelande:

 

Biblioteket kunde inte öppnas.

Biblioteket "Album xxx.photoslibrary" kunde inte identifieras.

 

Å det här händer efter att reparerandet kommit till 5 % klart.

 

Inte identifieras...? Efter 5 % och ett par timmars tuggande...?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×