Jump to content
Just nu i M3-nätverket

OS X El Capitan - Noob fråga angående uppdatering


ILoveMusic

Recommended Posts

Hej!

Jag försökte att ladda ner Xcode från app-store men det stog såhär:

"Xcode kan inte installeras på ”Namnlös” eftersom OS X version 10.10.5 eller senare krävs."

Jag har då Version 10.9.5 och inga nya uppdateringar finns tillgängligt så att jag kan ladda ner Xcode.

 

Nu till frågan: Kommer jag att förlora allt jag har installerad på datorn? OM jag installerar "OS X El Capitan" version? Kommer jag gå förlorad om bilder, musik, program osv.osv.

 

Tack på förhand.

Link to comment
Share on other sites

Nej, inte om allt går som det ska. Givetvis gör du en backup på dina viktiga filer med en extern hårddisk. Innan du uppdaterar till El Capitan bör du också göra en säker start först, du håller nere skifttangenten vid uppstart, loggar in och startar sedan om. Innan du uppdaterar kollar du så klart om du riskerar att förlora kompatibilitet med andra program. Se här: https://roaringapps.com/apps?platform=osx

Link to comment
Share on other sites

Du kan ta ner en tidigare version av Xcode på ADC.


Skaffa en login där och kolla på: https://developer.apple.com/xcode/download/

Nere till vänster klicka på Additional tools: https://developer.apple.com/downloads/

post-64246-0-20426700-1457732337_thumb.png

- - -

Behöver du hela Xcode, eller bara CLI-tools?

Är det bara byggverktygen kan du automatiskt installera dem i Terminalen.

xcode-select --install

http://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/

Tror man får godkänna avtal och lite annat med där, i Terminalen.

Link to comment
Share on other sites

Tack Alix och även iEricF.

 

Umm.. jag är så usel på sånt Alix, och vet inte ens vad kompatibilitet innebär..

 

Jag är den mest noobaste personen haha, jag tror att jag behöver hela xcode, jag vill lära mig kunna göra appar och förstår mig inte på om jag behöver bara CLI-tools för att kunna göra appar.

 

Jag kollar youtube från grund och botten på hur man använder sig av Xcode.

Link to comment
Share on other sites

... jag är så usel på sånt Alix, och vet inte ens vad kompatibilitet innebär.. ...

= Om ditt program funkar med El Capitan eller inte. Grön prick om det gör det.

Link to comment
Share on other sites

= Om ditt program funkar med El Capitan eller inte. Grön prick om det gör det.

Jaha nu företog jag! Och nej, det gör det inte tyvärr.

 

 

Skaffa en extern hårddisk och starta Time Machine för att göra en backup.

 

https://support.apple.com/sv-se/HT201250

 

Tack för länken, ska kika och läsa noggrant!

Link to comment
Share on other sites

Jag är den mest noobaste personen haha, jag tror att jag behöver hela xcode, jag vill lära mig kunna göra appar och förstår mig inte på om jag behöver bara CLI-tools för att kunna göra appar.

Skall du göra hela appar med grafik/GUI osv, behöver du Xcode som har alla SDK. Och det kan ju vara bra då om du har senaste så du får de senaste filerna.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...