Gå till innehåll
Just nu i M3-nätverket

Felsökning av Mac OS X


thevil

Rekommendera Poster

Pocahontas

Ett litet tips om en inställning i Finder, som jag så när glömt bort.

Men när man retat sig på en sak tillräckligt länge så får man göra något åt det.

 

Har man som jag flera externa hårddiskar, och vill starta upp från den externa, så ville jag att den hårddisken skulle hamna överst uppe till höger i fönstret efter start.

 

Nu har den inte gjort det sedan jag installerade Leopard för länge sedan, och det retade mig, och jag mindes inte vad som styrde det, men jag letade i Finder och kom på vad jag glömt.

 

I Finders meny >Innehåll finns Visa visningsalternativ

Och det var där man kan ändra från Inget till Ordna automatiskt.

 

post-113-1219152301_thumb.jpg post-113-1219152293_thumb.jpg

 

 

Enkelt, men inte alltid lätt att hitta.

Men nu ligger min externa disk övert uppe till höger på skrivbordet :skondans:

Länk till inlägg
Dela på andra webbplatser
  • Svars 63
  • Created
  • Senaste svar

Mest aktiva i detta ämne

  • Pocahontas

    13

  • Matrix

    4

  • Jesper Landen

    4

  • Semmelman

    3

Mest aktiva i detta ämne

Populära inlägg

Felsökning av Mac OS X.   Det finns väl fyra olika sätt att hantera fel. 1. Strunta i orsaken till felet och försöka laga det med generella lagningsmetoder. 2. Hitta orsaken till felet och komma p

Uppladdade bilder

Min Powerbook G4 har fram till senaste uppdateringen av Leopard fungerat finfint.

Jag har två stycken PowerMac G5 av den sista modellen som gjordes (oktober 2005), samt en PowerBook G4 17" 1GHz som är drygt 5 år gammal. Alla de maskinerna fungerar klockrent med Tiger. I Leopard har jag haft kernel panics på min ena G5 flera gånger, och också på min PowerBook. Det är många saker som inte är som de ska i Leopard.

 

jag tycker ändå att Mac OS X har blivit allt mer komplicerat och buggigt med tiden. Jag funderar allvarligt på att se om inte Linux kan vara ett alternativ, eller kanske Windows XP. Jag gillar inte Windows, men jag tycker inte att det krånglar lika mycket som Mac OS X.

Jag instämmer helt, förutom att jag inte ser Windows som ett alternativ för mig. Det blir nog Ubuntu på min arbetsmaskin, och Debian på den maskin som jag ska ha som server.

 

Jag tycker i alla fall att Mac OS X inte har blivit stabilare med tiden, och att tappet i stabilitet inte uppvägs av nya funktioner.

Nej, det har blivit tvärtom. Det har blivit instabilare med tiden. Jag har haft KP med Tiger i betaversion och så, men aldrig med en skarp version, förrän med Leopard, och då talar vi inte bara om 10.5.0 utan om 10.5.2 och 10.5.4, som borde ha hunnit bli hyfsat stabila.

 

Innan ni kommer med en massa motkommentarer om tredjeparts drvrutiner med mera: Jag köpte en ny hårddisk för några veckor sedan, och gjorde då en REN installation av Leopard, och körde Combouppdatering till 10.5.3. Då funkade deet någorlunda, men så kom uppdatering till 10.5.4 och det var en massa saker som bara la av att fungera.

 

Jag tillhör den skara Macanvändare som förut har "missionerat" till en viss del, därför att det faktiskt har vairt så att det "bara fungerade". Så är tyvärr inte fallet längre. Det verkar vara massvis med problem med Apple QA (Quality Assurance), både vad gäller hårdvara och mjukvara. Jag var nog en sådan som vissa PC-nissar hade kallat Mac-taliban förut, men det var inte för att dissa andra, utan för att om man verkligen tycker att något är bra, så vill man ju dela glädjen, och rekommendera en bra produkt till andra.

 

I dagsläget skulle jag nog inte rekommendera någon att köpa Mac. Jag kommer i all fall att avvakta och se om Apple tar de problem som finns på allvar.

 

Hälsar Alix, ännu så länge Mac-fantast, men som ska testa Ubuntu på sin iBook vad det lider. Ge gärna din synpunkt på om det har blivit mer eller mindre felsökande i Mac OS X-miljö, eller om du tycker att det har blivit bättre.

Det har i alla fall blivit fler ominstallaioner sedan Leopard kom. Jag har installerat om Leopard TVå gånger, och är på väg att göra det en tredje gång nu. Innan Leopard körde jag bara en arkivera och installera när det kom en ny version i butik, dvs från 10.2 -> 10.3 -> 10.4 -> 10.5, men efter att jag hade installerat t.ex 10.4 så körde jag bara uppdateringar.

 

"Det bara fungerar", som gällde förut verkar tyvärr vara historia nu.

Länk till inlägg
Dela på andra webbplatser
Pocahontas

Då är man inte ensam om att ominstallera, nu har jag visserligen inte gjort en grundlig ominstallation, utan bara Arkiv/Install, men jag är inte nöjd ändå.

Inte för att jag har några haverier, utan för att den känns "trög" på något vis, och som jag nämnt i annan tråd, seg uppstart och avstängning.

 

Felet jag möjligen gjort är att jag aldrig gjort en ren installation av Leopard, utan uppdaterat från mitt första Mac Os X (10.1)

till Jaguar >Panther> Tiger och så Leoparden, och allt skräp hängt med varje gång,

En grundlig städning av diverse program som aldrig används och få bort hundratals skräpfiler i biblioteken kanske inte skulle skada.

Jättejobb känner jag på mig att installera om alla program jag använder på nytt, men det är kanske det som behövs..

Nu använder man ju inte allt dagligen, så man får ta det allt eftersom.

Länk till inlägg
Dela på andra webbplatser
  • 4 months later...
Jesper Landen

Hjälp

Min PB G4 1.67 har lagt av.

Det började med att den gick oerhört långsamt och nu vägrar den att starta.

Jag har provat det mesta men utan resultat. Den visar "förloppssnurran" men kommer aldrig igång.

Jag har försökt att starta från CD men den vägrar, jag har försökt att använda den som FW-disk men min andra dator hittar den inte.

 

Några tips?

 

Jesper

Länk till inlägg
Dela på andra webbplatser
Pocahontas

Hittar du inte hårddisken i Target Mode med hjälp av Firewire, och inte heller med installationsskivans skivverktyg, så är det med all sannolikhet så att hårddisken har rasat helt för dig.

 

Du har väl backup förhoppningsvis

Länk till inlägg
Dela på andra webbplatser
Jesper Landen
Hittar du inte hårddisken i Target Mode med hjälp av Firewire, och inte heller med installationsskivans skivverktyg, så är det med all sannolikhet så att hårddisken har rasat helt för dig.

 

Du har väl backup förhoppningsvis

 

Självklart har jag backup ;-)

Den burken har inget viktigt i sig.

 

Jag kan inte få den att starta från CDn

Länk till inlägg
Dela på andra webbplatser
Pocahontas

För att vara säker på att du gör rätt..

 

Du sätter i den installationsskiva som medföljde datorn, startar om datorn, håller ner c-tangenten.

 

Då ska datorn starta upp från skivan, du ska i så fall välja språk, och efter det gå upp i menyn till Verktyg.

 

Går inte det heller?

Länk till inlägg
Dela på andra webbplatser
Jesper Landen
För att vara säker på att du gör rätt..

 

Du sätter i den installationsskiva som medföljde datorn, startar om datorn, håller ner c-tangenten.

 

Då ska datorn starta upp från skivan, du ska i så fall välja språk, och efter det gå upp i menyn till Verktyg.

 

Går inte det heller?

 

den tuggar och tuggar men det händer inte så mycket

 

jag har provat med Tiger-skivan men jag får väl prova med den skivan som följde med

Länk till inlägg
Dela på andra webbplatser
  • 8 months later...
elias.nyberg

Lever den här tråden?

 

Eftersom en av hushållets macbookar (den med tiger på), inte ville ta emot de filer som spelats in med en videokamera (detta fel kan vi diskutera senare i en annan tråd), tänkte jag att "aha, här behöver vi:

  1. 1. köra programuppdatering för att få en fräschare version av det förinstallerade imovie och quicktime
  2. 2. lasta hem perian och flip4mac
  3. 3. klappa datorn snällt och hoppas på det bästa"
  4. (samtidigt hade den andra användaren (mitt ex) kört igång någon slags uppdatering till ms-office (nåt om xml-jadajada hann jag läsa))

 

Så vi körde igång programuppdateringen, samtidigt som vi uppdaterade flip4mac och installerade perian. Innan programuppdateringen var klar, blev f4m och perian klara, sa tack för en trevlig installation och jag matade ut skivavbilderna. (nu gick det åtminstone att öppna filmfilerna i VLC, men fortfarande inte i iMovie eller quicktime.

 

MEN!!! När programuppdateringen var klar (den enda variabeln jag är lite osäker på i fallet är den där ms-office-uppdateringen), började datorn starta om i frid och fröjd, vi fick höra mac-plingen (som ju ska vara ett tecken på att allt är frid och fröjd). Därefter kommer en blå skärm upp, med en rund vänt-greja (som snurrar, och inte är en badboll). Efter en stund försvinner väntgrejan och ersätts av en vanlig svart muspekare, men inga fönster att klicka i, och ingen menyrad. Detta oavsett hur många gånger jag startar om den.

 

Burken vill inte starta i safe-mode (genom att hålla in skift vid uppstart). Ej heller verkar den vara så pepp på att starta i safe-mode via kommandon inskrivna i single-mode. I single-mode har jag också kört fsck som säger att "hårddisken verkar vara ok". Från single-mode har jag kört Verbose-uppstart (eller vad dom nu kallart), som berättar varje kommandorad i uppstartsproceduren och hur det gick att köra den. Efter en stund hamnar datorn i samma läge som innan (jag hade hoppats att den åtminstone kunde skriva i vitt på svart vilken rad som inte funkade) -med den skillnaden att den då växlar mellan "blå skärm med väntgreja" och "svart skärm med fet textmarkör"... (jag gillar ingen av dem)

 

Jag stoppade i mina Leopard-skivor (eftersom tiger-skivorna inte är här) och startade upp tiger-burken för att få igång skivverktygen. Så jag har reparerat skivbehörigheten, och den säger att dom är okej nu (men inte var det innan). Inte heller efter detta har det märkts någon skillnad.

 

Nu har jag testat att rensa parameter-ram, men det verkar inte heller göra någon skillnad.

 

  • [-] Finns det något annat bra sätt att starta i safe-mode än de ovan beskrivna?
    [-] Nån som varit med om något liknande?
    [-] Finns det något smidigt sätt att starta systemet där verktygsprogammen finns utan att stoppa i startskivor?
  • Är time machine enda sättet att göra systemåterställningar till "senast fungerande konfiguration" eller "så som det var den 20 september"?
    [-] Finns det något lagligt sätt att ladda ner iso-filer till startskivor man redan har licens för?

 

 

Hoppas någon kan hjälpa till!

 

Elias (och Hannah)

Länk till inlägg
Dela på andra webbplatser
Pocahontas

Du kan inte reparera Tigers Skivbehörigheter med Leopard instyallationsskiva.

Man ska egentligen aldrig köra Reparera Skivbehörigheter från installationsskvan alls. Det körs "inneifrån" Verktygsmappen på hårddisken.

Reparera Skiva däremot är OK.

 

Vad du skulle göra är att om det är Tiger du hade på datorn, är att sätta i Tigers installationsskiva och köra en Arkivera/Installera

Eller om det är möjligt att ha Leopard på datorn, installera det på samma vis, dvs Arkivera/Installera

 

 

Hade du backup på allt innan du började

Länk till inlägg
Dela på andra webbplatser
elias.nyberg

kan inte = går inte att göra eller kan inte = om man gör det så går saker sönder? blev nu lite osäker på om jag körde reparera skiva eller reparera skivrättigheter... :unsure:

 

kan det hjälpa att reparera skiva för dom problem jag beskrivit? vad kan ha hänt (dvs. hur undviker jag det i framtiden)?

Länk till inlägg
Dela på andra webbplatser
Pocahontas

Prova du att köra Reparera skiva, från Tigers installationsskiva, ingenting "går i sönder" eller försvinner.

 

Alternativet är att du installerar Leopard på datorn, om det är en fristående version av Leopard (svart skiva), är det en grå är det en skiva som tillhör en specifik macmodell, den går inte, såvida det inte är likadana MacBooks ex.vis.

Välj då Arkivera/installara som jag länkade här ovan.

 

Då får du en ny fräsch Systemmapp, alla andra program, musik och dokument med mera bibehålls på hårddisken

Länk till inlägg
Dela på andra webbplatser

Har tyvärr ingen aning om vad felet kan vara. Dock undrar jag om det är så bra att installera en massa saker medans programuppdateringen rullar? Jag kanske är lite väl petig, men brukar alltid koppla ur externa diskar, stänga av program och låta bli att göra något annat än just köra programuppdatering.

Länk till inlägg
Dela på andra webbplatser
  • 1 month later...

Jag har fått problem med min mac pro. vid uppstart kommer den inte längre än till den gråa skärmen och cirkeln som snurrar runt.

 

Jag har provat att zappa pram men inget händer (den startar bara om sig själv tills jag släpper tangenterna igen).

 

Att hålla shift nere vid uppstart fungerar inte (den går vidare till den gråa bilden)

 

När jag startar från installtions DVDn och kör skivverktyg är det inget fel på HD och jag har reparerat behörigheterna.

 

Väljer jag sedan startskiva och startar om från HD igen är jag tillbaka på ruta 1 igen.

 

Alltså, det är inget fel på hårddisken enligt skivverktyg men ändå stannar uppstarten vid den gråa skärmen. Jag har dragit ut alla externa saker utom tangentbordet.

 

Har någon en lösning innan jag arkiverar och installerar?

Länk till inlägg
Dela på andra webbplatser
Pocahontas

Kör en arkivera installera

Länk till inlägg
Dela på andra webbplatser
Testa med att återställa SMC.

 

Blev lite fundersam när jag kollade på apples supportsida ang SMC:

 

To reset the SMC on a Mac Pro:

 

From the Apple menu, choose Shut Down (or if the computer is not responding, hold the power button until it turns off).

Unplug all cables from the computer, including the power cord and any display cables.

Wait at least fifteen seconds.

Plug the power cord back in, making sure the power button is not being pressed at the time. Then reconnect your keyboard and mouse to the computer.

Press the power button to start up your computer.

 

Ska jag inte koppla in skärmen igen tillsammans med nätsladd, mus och tangentbord :detvarintejag:

 

Jag har ingen SMC_RST switch på min modell och det där har jag provat utan resultat.

 

 

För övrigt kan jag tillägga att jag körde safe boot (eller vad det heter) med shift-command-v så att det rabblas en massa text och när mitt kontonamn började matas upp stod det en massa failure hit och dit.

 

Startar jag datorn i FW-target mode kommer jag åt allt på HD så det blir till o backa upp allt en extra gång och arkivera installera...

Länk till inlägg
Dela på andra webbplatser

SMC_RST switchen sitter ovanför minnena, rätt in på moderkortet. Men det är nog inget fel på SMC i det här fallet.

Om du kör i FW-target mode så kan du läsa av vad texten innehöll om du kollar i Systemmeddelanden på MP'n.

Länk till inlägg
Dela på andra webbplatser
SMC_RST switchen sitter ovanför minnena, rätt in på moderkortet. Men det är nog inget fel på SMC i det här fallet.

Om du kör i FW-target mode så kan du läsa av vad texten innehöll om du kollar i Systemmeddelanden på MP'n.

 

Men enligt apple har mac pro från tidiga 2008 inte denna switch utan man återställer SMC genom att dra ut ALLA sladdar, väntar minst 15 sek. och sedan starta om den igen...detta har jag alltså gjort utan framgång

Länk till inlägg
Dela på andra webbplatser
Men enligt apple har mac pro från tidiga 2008 inte denna switch utan man återställer SMC genom att dra ut ALLA sladdar, väntar minst 15 sek. och sedan starta om den igen...detta har jag alltså gjort utan framgång

 

Aha! En liten luring. Apple har tydligen smugit in en Kameleont i bohaget. :D

Länk till inlägg
Dela på andra webbplatser
  • 2 weeks later...

Hej, jag är inte säker påom jag hittat rätt diskution men min fråga gäller min gamla ibook som inte startar som den ska. Fäljande händer. Först kommer jag in på sidan med de två användar kontona som datorn har. När jag klickar på mitt konto för att logga in så hamnar datorn i unix mode, som ber efter mitt användar namn, därifrån kan jag bara komma vidare ifall jag knappar in mtt lösenord ( inte användarnamn och lösen ord utan bara lösenordet där användar namnet igentligen ska vara). När jag sedan väl kommer in så tar det jätte lång tid för datorn att bli klar att användas. Jag har provat att reparera med skiv verktyget etc etc men inget verkar hjälpa. Finns det någon som kan hjälpa mig att lösa detta?? Hälsningar N

ps mitt operativ system är tiger och jag kan inte hitta mina gamla installation skivor)

Länk till inlägg
Dela på andra webbplatser
  • 1 month later...

Har samma problem som iMartin just nu, får igång ubuntu dock som jag har parallelt . Får väll testa att göra en arkivera och installera..

Länk till inlägg
Dela på andra webbplatser
  • 2 weeks later...

:totaltgalen: Kan en venlig själ dissekera denna rapport? Tack.

 

panic(cpu 0 caller 0x000D6950): bremfree: lost tail

Latest stack backtrace for cpu 0:

Backtrace:

0x000954F8 0x00095A10 0x00026898 0x000D6950 0x000D8DC8 0x000D6678 0x0023A9D8 0x00231FE8

0x000E4844 0x002320B8 0x000F9804 0x000EC884 0x000E8F64 0x000EC8D0 0x002ABDB8 0x000ABD30

0x00000003

Proceeding back via exception chain:

Exception state (sv=0x3D556C80)

PC=0x9003BB6C; MSR=0x0200F030; DAR=0xE0006000; DSISR=0x42000000; LR=0x00002FCC; R1=0xBFFFFD80; XCP=0x00000030 (0xC00 - System call)

 

Kernel version:

Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC

Model: PowerMac3,6, BootROM 4.6.0f1, 2 processors, PowerPC G4 (3.3), 1.25 GHz, 1.75 GB

Graphics: ATI Radeon 9000 Pro, ATY,RV250, AGP, 64 MB

Memory Module: DIMM0/J21, 512 MB, DDR SDRAM, PC2700U-25330

Memory Module: DIMM1/J22, 512 MB, DDR SDRAM, PC2700U-25330

Memory Module: DIMM2/J23, 512 MB, DDR SDRAM, PC2700U-25330

Memory Module: DIMM3/J20, 256 MB, DDR SDRAM, PC2700U-25330

AirPort: AirPort Extreme, 405.1 (3.90.34.0.p18)

Modem: V.90

Bluetooth: Version 1.9.5f4, 2 service, 0 devices, 1 incoming serial ports

Network Service: Ethernet (inbyggt), Ethernet, en0

PCI Card: pci11de,6057, sppci_video, SLOT-3

PCI Card: usb, usb, SLOT-4

PCI Card: usb, usb, SLOT-4

PCI Card: pci1033,e0, SLOT-4

PCI Card: pci10ee,3fc4, sppci_audio, SLOT-5

Parallel ATA Device: WDC WD3200AAJB-00TYA0, 298.09 GB

Parallel ATA Device: Optiarc DVD RW AD-7191A

Parallel ATA Device: TOSHIBA DVD-ROM SD-R1312

Parallel ATA Device: IBM-IC35L080AVVA07-0, 76.69 GB

Parallel ATA Device: WDC WD2000JB-00GVA0, 186.31 GB

USB Device: Hub, Up to 12 Mb/sec, 500 mA

USB Device: ProtectExecuter, Syncrosoft, Up to 12 Mb/sec, 500 mA

USB Device: Unitor8 MkII, Emagic GmbH, Up to 12 Mb/sec, 500 mA

USB Device: ProtectExecuter, Syncrosoft, Up to 12 Mb/sec, 500 mA

USB Device: USB Device, Up to 480 Mb/sec, 500 mA

USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA

USB Device: USB RECEIVER, Logitech, Up to 1.5 Mb/sec, 100 mA

USB Device: Bluetooth USB Host Controller, Up to 12 Mb/sec, 100 mA

USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA

Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...