Jump to content
Just nu i M3-nätverket

Kan man köra Leopard på nya MacBook Pro


Knotan

Recommended Posts

Min sambo kör en gammal MacBook 2.1 med Leopard (10.5.8). Nu har hon köpt en MacBook Pro med Mountain Lion (10.8.2)

 

Ett problem är att hon har en gammal PowerPC-version av Filemaker och som därför kräver Rosetta-tolken för att köras i en Intel-Mac, men någon Rosetta-tolk finns inte längre i Mac OS. Att uppgradera Filemaker kostar 4200 kronor men hon använder inte Filemaker tillräckligt mycket att vi tycker att det är värt det priset. Bento heter en billigare variant, men hon har lagt ned så mycket jobb på att få bokföringen att funka så hon vill inte börja om från början igen. Alternativet är i så fall att behålla den gamla MacBooken enbart för att köra bokföringen på.

 

Fråga 1: Finns det en Rosetta-tolk, som man kan installera i Mountain Lion?

 

Jag klonade hennes gamla system till en extern disk och det går utmärkt att boota från den klonade disken på hennes gamla dator. Sedan monterade jag disken på den nya datorn och när jag tryckte ned alt-tangenten vid start erbjöds jag att boota från externa disken, men till min stora besvikelse fick jag omedelbart kernel crash. Däremot går det att använda den externa disken, men tydligen inte som boot-disk.

 

Fråga 2: Skall det vara så?

Link to comment
Share on other sites

Fattar inte. Vad är det du kör? Snow Leopard på en mid-2012 MacBook Pro? Hur?

Det är en late-2011 MBP 17" 2.4 GHz Intel Core i7.

 

Jag har skrivit rätt detaljerat om hur jag bar mej åt. Nånstans, ja. Men hittar inte texten nu (skit); kanske var på nåt annat forum? Hinner tyvärr inte utveckla instruktionerna just nu. Men annars är svaret JA, jag har en (stor) partition med Mt Lion, kliniskt ren från allt som andas eller luktar PowerPC och en mindre partition med Snow Leopard, där allt PowerPC jag ville ha kvar är samlat, plus några program (UB och Intelarkitektur) som är bra att ha även på den partitionen, men som jag huvudsakligen kör i Mt Lion (det är ju där jag är mest, kanske 95%). Rosetta finns på Snow L och faktiskt gör sitt jobb klanderfritt. Apple Works (RiP?), t.ex. funkar lika bra som det nånsin har gjort (10 år sen, eller ngt däråt?) :)

 

Båda partitionerna bootar och är förstås helt oberoende av varandra. Skivverktyg, TechTool Pro o dyl finns på båda partitionerna och kan användas mot respektive ej-startskiva, osv osv. Jag brukar, direkt efter uppstarten, mata ut den "andra" skivan så den inte är i vägen, men annars funkar dom i förhållande till varandra på exakt samma sätt som start- och externa skivor gör. Enda skillnaden här är att de ligger på samma hårddisk.

 

Time Machine funkar helt normalt och det gör SuperDuper också.

 

Lösningen är kanon för mina behov samt att mina (begränsade) kunskaper klarar av att hantera den.

 

Jag får väl återkomma senare ifall du/andra har frågor och funderingar kring tillvägagångssättet.

post-12618-031081100 1354924754_thumb.jpg

Link to comment
Share on other sites

En helt annan möjlighet är att leta efter lite nyare versioner av FileMaker Pro på Blocket och Tradera. Jag har hittat flera versioner för cirka 500 kronor. Leta bland PC-program också - skivorna är ju gemensamma för PC och Mac och många förstår inte vad FileMaker Pro är för program.

 

Jag kör själv FMP 9 på IntelMac, jag har ingen riktig koll på när de blev Dual Binary eller vad det heter.

 

Bento är nog inget alternativ, det är tänkt för andra uppgifter.

Link to comment
Share on other sites

Förresten: kan man inte installera Parallells Desktop eller VMWare Fusion och installera Leopard eller rent av OS 9 där?

Link to comment
Share on other sites

Men trådskaparen lär ju ha en mid-2012, kan den verkligen köra SnowLeopard?

Kan du förklara varför det skulle göra nån skillnad?

Är du själv intresserad av att få det att funka så som beskrivet, eller har ditt intresse mera "akademisk" karaktär, typ "kritiskt tänkande" etc ;)

Jag är ganska pragmatisk i mitt datoranvändande; mest intresserad av vad den gör, inte kan. Som humlan, ungefär.

Link to comment
Share on other sites

Kan du förklara varför det skulle göra nån skillnad?

Är du själv intresserad av att få det att funka så som beskrivet, eller har ditt intresse mera "akademisk" karaktär, typ "kritiskt tänkande" etc ;)

Jag är ganska pragmatisk i mitt datoranvändande; mest intresserad av vad den gör, inte kan. Som humlan, ungefär.

 

10.6.8 lär ha fel/för gammal kernel så operativsystemet kommer inte starta över huvud taget tyvärr.

Kan testa på måndag för att få det bekräftat men är tämligen säker på att en 13" mid-2012 kräver minst 10.7.4

Link to comment
Share on other sites

10.6.8 lär ha fel/för gammal kernel så operativsystemet kommer inte starta över huvud taget tyvärr.

Kan testa på måndag för att få det bekräftat men är tämligen säker på att en 13" mid-2012 kräver minst 10.7.4

OK, intressant. Jag kanske har fel, men har för mej att min MBP, när den levererades med Lion, gratis uppgraderingsbar till Mt Lion, inte heller skulle gå att köra Snow eller ev Leopard (utan Snow). Vilket av det är rätt eller fel vet jag inte säkert nu, men alltså Snow visade sej gå alldeles utmärkt, bara man har tömt den på allt "nativ" PPC-kod. Snow och Mt Lion är två suveräna system, vart och ett bäst på sitt sätt, så det är en klart gångbar konstellation, i dagsläget. Skulle faktiskt vara riktigt kul att få bekräftat att samma konfiguration gick att ha på mid-2012 också, men du är alltså mer än skeptisk till det, teoretiskt alltså, än så länge.

Få se om du lyckas/kan skaka fram nån viljestark brumbrum-humla, som inte heller kan men skiter i det...

Link to comment
Share on other sites

Och förresten, late-2011 serien har väl en hel rad olika processorer, vilket mid-2012 också har. Har det någon betydelse i praktiken, eller hänger det helt och hållet på om kernelversion är knuten till en viss "tidpunkt", oavsett processortyp, prestanda osv? Borde isf kernelversioner vara rätt så "svårhackade".

Link to comment
Share on other sites

Late-2011 är Sandy-bridge baserad precis som early-2011. Igentligen är det inte mycket alls som skiljer en early från en late 2011 och early levererades i början med SnowLeopard vilket även gör late 2011 också kan köra SnowLeopard. Mid-2012 har en helt ny hårdvaruarkitektur med ivy-bridge styrkretsar som SnowLeopard saknar stöd för.

Även om man efter mycket om och men lyckas mecka in kext-filer från MountainLion och få snowleopard att fungera så vet jag att någon tidig filemakerversion som fungerade bra i leopard inte kunde skriva ut optimalt i SnowLeopard så uppgradera filemaker som är det egentliga problemet är helt klart bästa lösningen.

Link to comment
Share on other sites

Tack för alla svar.

 

 

Jag inser nu att för att det skall funka måste min disk ha en kernel för ny hårdvara tillsammans med Snöleopardens Mac OS. Den kombinationen finns inte. Min externa disk har en kernel för den gamla hårdvaran och kraschar blixtsnabbt.

 

 

Kan man med hjälp av Apples utvecklarverktyg skapa en ny laddmodul. i vilken man länkar ihop en ny kernel med ett gammalt MacOS? Är vi för långt bort från Cupertino för att det skall gå?

 

 

Link to comment
Share on other sites

Om du googlar "Ivy Bridge kernel for Snow Leopard 10.6.8" så finns diverse Hackintosh nördar som fixat detta redan. Hur man rent praktiskt går tillväga vet jag tyvärr inte men du får läsa runt på googleträffarna så finns säkert guider. Är nog kanske inte helt lätt och problemfritt. Antar att det även kan vara buggigt.

Vilken FileMakerversion körs på den gamla datorn?

Link to comment
Share on other sites

Förresten: kan man inte installera Parallells Desktop eller VMWare Fusion och installera Leopard eller rent av OS 9 där?

 

Nej, jag hade nog fel där. (Konstigt att ingen har rättat mig!) Jag hade för mig att man kunde installera även Mac OS i Parallells och Fusion, men det verkar inte gå. Sheepshaver är tydligen enda möjligheten. Synd, jag hade sett fram emot att pröva att installera OS 9.2.2 på MacMinin. Inte för att jag vet vad jag skulle ha det till. Sitta och gråta kanske: "Ååh, så trevligt det var på den tiden"?

Link to comment
Share on other sites

VirtualBox (gratis virtualiseringprogram) har numera stöd för virtuell Mac OS X på Macar. Läs mer här eller se dump i spoiler nedan. Jag har inte testat för egen del.

 

 

post-28798-056394700 1355159244_thumb.png

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...