Jump to content
Just nu i M3-nätverket

DHCP har slutat att fungera


Kabo

Recommended Posts

Bakgrund: Vi har haft internet via ADSL i sex eller sju år. Under hela den tiden har det varit inställt att ta emot med DHCP.

I ca fem av de sju åren har vi ibland haft en trådlös router. Det har inte varit några problem att växla mellan router och enbart modem, annat än det vanliga; man måste vänta ett tag innan man får ett nytt ip-nummer. Routern var senast borta från mitten av januari fram till påsk då den sattes tillbaka och har sedan varit på plats. Allt har fungerat klanderfritt.

 

Två datorer är testade både med router och direktkoplat till modemet. En ibook g3 med 10.4 samt en PM G4 med 10.4 Det har fungerat att komma ut på enternet både via router och direkt från modem.

 

En uppdatering gjordes i början av juni på G 4:an men så vitt jag kan minnas handlade det bara om program; jag kan minnas fel. Inga uppdateringar har gjorts på G 3:an.

 

Problem:Söndag 3 jul upphörde internetuppkopplingen att fungera. Gjorde alla normala omstarter utan resultat.

Kopplade bort routern för att kolla om den var felkällan men de gav ingen skillnad.

Jag trodde problemet dök upp plötsligt men nu säger sonen som var den som satt vid datorn att det först började krångla så han inte kom ut på vissa sidor och sedan försvann allt. Det han ägnade sig åt var att kolla priset på bussar resp tågbiljetter. Internet drog sin sista suck när han skulle vidare i ett beställningsförfarande.

Inbyggt ethernet, nätverksinställningar och internetleverantör har gröna prickar när jag gör en diagnos. Internet och server får däremot röda prickar. Samma sak oavsett om jag försöker ansluta med eller utan routern ikopplad.

 

Oändliga samtal med internetleverantörens service har inte kunnat lösa problemet.

Första budet från leverantören var att modemet var trasigt. Vi köpte ett nytt som inte heller fungerar (på samma sätt)

Nu hävdar man att problemet är macrelaterat och att man måste ha en router för att det ska fungera med mac. Etersom det inte fungerar är det antagligen routern som är trasig. Jag vill inte kasta ut ytterligare 500:- på en ny router i onödan; det räcker med ett onödigt modem.

 

Av en ren slump upptäckte jag att det gick att komma ut på nätet om jag ändrade till BootP men det fungerar inte med routern.

Det kan vara routern som blivit trasig även om jag tycker det verkar märkligt att routern, och DHCP funktionen på två datorer ska ha slutat fungera samtidigt. Och om nu problemet är macrelaterat när blev det så efter 7 år och vad har utlöst det? En uppdatering hos mig eller hos leverantören.

 

 

Snälla hjälp mig att lösa problemet eller åtminståne få lite bränsle som jag kan elda på med när jag pratar med leverantörens tekniker

Link to comment
Share on other sites

Okej.

 

Gjort reset på routern? Hållt inne reset-knapp eller lknande och återställt alla inställningar samt sedan installerat den från "scratch"?

 

Får routern ett IP av modemet när det sedan kopplats in och ställts in efter din reset?

 

Har du problem att komma åt routern kan du tillfälligt använda fasta IP-adresser på någon av dina datorer för att komma åt routern via sitt webbgränssnitt.

Link to comment
Share on other sites

Jag har startat om routern grundligt med "pinne i hål"

Jag kan komma in i routern och ställa in det jag ska och vid test säger den att en internetanslutning finns men sen när den ska dirigera mig till netgears hemsida är jag i alla fall inte ute på internet. Problemet är väl i så fall att jag inte är hundra säker på vad som ska ställas in eftersom jag aldrig behövt göra det förut- det har skött sig själv. Enda gången jag varit in i routern är när jag uppdaterat firmware och det är nåt år sen.

 

Diagnosen visar exakt samma sak varesig jag har routern kopplad eller direkt till modemet.

Link to comment
Share on other sites

Brukar finnas en snabbinställnings-guide som man kan följa när man installerar en router "första" gången.

 

Kanske har du problem med DNS.

Ställ in en egen DNS på din dator.

 

8.8.8.8 är en DNS som google håller i.

Link to comment
Share on other sites

Jag har använt snabbinställningen. Det är då den säger att en internetanslutning finns. Sen hoppar den till ett läge där den tycks anse att jag inte får ip-nr automatiskt från min lev.

Enligt servicesamtal "begär" mac fel sorts nummer och det är därför problemet beror på mac och enligt dom ska man ha en router för att det ska funka.

Frågan är hur jag ska kunna kolla att routern verkligen funkar men nog tycker jag det verkar ok.

Link to comment
Share on other sites

Jag har använt snabbinställningen. Det är då den säger att en internetanslutning finns. Sen hoppar den till ett läge där den tycks anse att jag inte får ip-nr automatiskt från min lev.

Enligt servicesamtal "begär" mac fel sorts nummer och det är därför problemet beror på mac och enligt dom ska man ha en router för att det ska funka.

Frågan är hur jag ska kunna kolla att routern verkligen funkar men nog tycker jag det verkar ok.

Jag trodde du hade routern inkopplad?

Det jag har sagt ovan är för routern.

 

Om du kopplar in routern och ställer in den och sedan tar dig in i dess web-interface och kollar hur det ser ut på WAN-sidan.

Oftast finns en info-sida där man kan se vilket IP som tilldelats från modemet samt DNS-address osv.

Ser dom OK ut så har routern en ordentlig uppkoppling iaf.

 

Det var i detta tillfälle som jag tyckte att du borde testa med en egeninställd DNS(8.8.8.8) och IP-adress(inom lokala nätverket) på din dator för att se om DNS'en är knasig antingen från din ISP eller i din router.

 

[TILLÄGG]

För att svara på dina bilder. BOOTP ska du inte använda. Men testa att ställ in en egen DNS(8.8.8.8) i DNS-rutan.

Link to comment
Share on other sites

Om jag inte använder BootP kommer jag överhuvudtaget inte ut på internet. Det fungerar bara om jag inte har routern inkopplad.

Jag har alltid haft DHCP förut innan det slutade fungera. Det fungerar varken med eller utan router.

Nu får jag växla mellan de båda eftersom jag måsta ha DHCP när jag mecklar med routern och BootP för att kunna söka svar och ställa frågor på internet.

Jag får väl koppla routern till den andra datorn så att jag kan läsa och ställa in samtidigt.

Menar du att jag ska skriva in "åttorna" vid dns rutan ovan?

Men ip? Det kan man väl inte bara uppfinna ett?

 

För övrigt. I båda bilderna ovan står ett ip-nr för router trots att den inte är ikopplad. Jag har för mig att den rutan var tom på den tiden allt fungerade som det skulle när jag var direktkopplad på modemet.

Link to comment
Share on other sites

Nu har jag kollat i routern. den verkar inte få något ip-nr från modemet. Det står bara 0:or i statusen.

 

Routern fungerar i interna nätverket både med sladdar och airport.

Link to comment
Share on other sites

Om jag inte använder BootP kommer jag överhuvudtaget inte ut på internet. Det fungerar bara om jag inte har routern inkopplad.

Jag har alltid haft DHCP förut innan det slutade fungera. Det fungerar varken med eller utan router.

Nu får jag växla mellan de båda eftersom jag måsta ha DHCP när jag mecklar med routern och BootP för att kunna söka svar och ställa frågor på internet.

Jag får väl koppla routern till den andra datorn så att jag kan läsa och ställa in samtidigt.

Menar du att jag ska skriva in "åttorna" vid dns rutan ovan?

Men ip? Det kan man väl inte bara uppfinna ett?

 

För övrigt. I båda bilderna ovan står ett ip-nr för router trots att den inte är ikopplad. Jag har för mig att den rutan var tom på den tiden allt fungerade som det skulle när jag var direktkopplad på modemet.

Okej, jag ser hur du testar.

Problemet ligger någonstans i routern. Kanske går det att komma åt dem.

När du kopplat in router och datorn till routern kan du sätta en egen IP-adress för din Mac inom det interna nätverket.

Du kan då "uppfinna" din egen fasta IP-adress inom det egna nätverket.

Från din andra bild ser jag att den interna DHCP-tilldelningen från din router fungerar. Du har ju blivit tilldelad IP 192.168.0.194 inom det interna nätverket.

 

Skulle den ej fungera kan du själv välja ett IP inom det interna nätverket.

Jag ser att din router har IP 192.168.0.1 du kan då välja vilket IP du vill inom intervallet 192.168.0.2-254.

Följ upp med en delnätmask på 255.255.255.0 och router 192.168.0.1 därefter en DNS om du vill testa en extern DNS.

 

Jag skulle gå in i routerns inställningar och kolla till WAN-inställningarna. WAN är den port som modemet ska vara kopplat till och är den port som all internet-kommunikation går genom. Du bör kolla över den portens inställningar. Ofta finns det en del i routerns web-gränssnitt helt dedikerat till WAN-inställningar. Dessa bör troligen vara inställda på DHCP(Om din ISP säger så) och där kan du troligtvis även klicka på knappar för att försöka påskynda en ny tilldelning av IP via DHCP.

 

Står det i web-gränssnittet att ingen kabel är ansluten till WAN-porten även fast det är en kabel kopplad eller liknande bör man testa med annan kabel osv. Men det finns en risk att den delen av routern är trasig.

 

Vad är det för router du använder egentligen? Modell/märke.

Link to comment
Share on other sites

Jag ser att din router har IP 192.168.0.1 du kan då välja vilket IP du vill inom intervallet 192.168.0.2-254.

Följ upp med en delnätmask på 255.255.255.0 och router 192.168.0.1 därefter en DNS om du vill testa en extern DNS.

 

Och här är kanske pudelns kärna; på bilden ovan med ip som börjar på 192.. Routern är inte ikopplad där utan datorn är kopplad direkt på modemet och den borde altså få en ip-adress som i den andra bilden. Modemet har inte inbygd router.

Link to comment
Share on other sites

Och här är kanske pudelns kärna; på bilden ovan med ip som börjar på 192.. Routern är inte ikopplad där utan datorn är kopplad direkt på modemet och den borde altså få en ip-adress som i den andra bilden. Modemet har inte inbygd router.

 

Du har helt rätt.... fundersam.gif

Link to comment
Share on other sites

Och nu helt plötsligt utan att jag gjort nånting med datorn, bara mixtrat med routern via den andra datorn, kommer jag ut på internet med DHCP direktkopplad till modemet och ingen router mellan modemet och datorn.

Link to comment
Share on other sites

post-6947-068290700 1310381790_thumb.png

Så ser det ut i routerstatus.

 

Det förefaller vara ett tudelat problem.

Jag kommer numer utan problem ut på internet med DHCP om jag kopplar direkt till modemet. Enligt servicekillen skulle det ju inte gå alls om man har mac. Alltså misstänker jag internetleverantören för att vara orsaken till problemet från början och att dom nu gjort något åt det.

Att vi inte märkt av några problem tidigare kan ju bero på att vi var kopplade till routern precis som dom sa att krävdes.

Om man tänker sig att routern havererade så skulle det kunna förklara varför allt slutade funka.

 

Jag kommer fortfarande inte ut på internet med routern ikopplad.

Link to comment
Share on other sites

Att de skyller på att du har en Mac är ren och skär okunskap. Du skulle lika gärna kunna sitta på en AS/400 eller en Atari ST och det ska fungera. Det handlar helt klart enbart om okunskap så fort det inte står Windows och Dell på datorn från leverantörens sida. chockadskeptisk.gif

 

Du har ju nu samma problem på din router som innan, dvs det får ingen extern IP från din internetleverantör via modemet utan den har också en intern 192.x.x.x-adress.

 

Du har stängt av modemet innan du kopplar in det i din router ifall den har låst mac-adressen mot din dators nätverkskort?

Link to comment
Share on other sites

Du bör fortfarande in i routerns inställningar och ändra.

En extern IP-adress på 192.168.2.107 stämmer inte.

 

Antingen följer du "Setup Wizard" längst upp till vänster i webgränssnittet.

Eller så kollar du under "Basic settings".

Link to comment
Share on other sites

Jag har följt setupwizard.

Statusen jag visade var resultatet av detta.

Link to comment
Share on other sites

Jag har följt setupwizard.

Statusen jag visade var resultatet av detta.

Testat reset-knappen på modemet? (Finns en på mitt gamla ADSL iaf.)

8-12 sekunder eller vad det nu brukar vara.

 

Annars är slutsatsen:

Antingen trasigt modem eller trasig router.

Link to comment
Share on other sites

Modemet är inte trasigt i alla fall.

Köpte ju ett nytt i onödan, ett nytt som gav exakt samma felmeddelande som det gamla.

Jag har testat med båda modemen och efter idag förmiddag går det utmärkt att komma ut på internet med DHCP så länge jag inte kopplar en router.

Routern kan alltså vara trasig.

På onsdag ska jag ta med den och sätta den på ett annat modem, på en annan ort med annan internetleverantör. Funkar det inte där heller får jag anse det som trasigt.

Det som gör mig lite fundersam är att när jag försökte mig på att ställa in i routern enligt råd ovan kom det upp en varningsruta om att inställningarna kunde kollidera med leverantörens och jag fick ett ip-nr som började på 10.

När jag skrev in -192.168.1.1 som vanligtvis är adressen till routern gick det förbi routern och jag hamnade i D-linkmodemets inställningssida. Uppenbarligen fungerar kabeln mellan routern och modemet i alla fall och någon typ av kontakt verkar finnas.

Link to comment
Share on other sites

Modemet är inte trasigt i alla fall.

Köpte ju ett nytt i onödan, ett nytt som gav exakt samma felmeddelande som det gamla.

Jag har testat med båda modemen och efter idag förmiddag går det utmärkt att komma ut på internet med DHCP så länge jag inte kopplar en router.

Routern kan alltså vara trasig.

På onsdag ska jag ta med den och sätta den på ett annat modem, på en annan ort med annan internetleverantör. Funkar det inte där heller får jag anse det som trasigt.

Det som gör mig lite fundersam är att när jag försökte mig på att ställa in i routern enligt råd ovan kom det upp en varningsruta om att inställningarna kunde kollidera med leverantörens och jag fick ett ip-nr som började på 10.

När jag skrev in -192.168.1.1 som vanligtvis är adressen till routern gick det förbi routern och jag hamnade i D-linkmodemets inställningssida. Uppenbarligen fungerar kabeln mellan routern och modemet i alla fall och någon typ av kontakt verkar finnas.

 

Ditt D-Link modem kan vara NAT'ad. Kanske du borde in i den och kolla lite också.

 

Också helt möjligt att modemet och routern stör varandra om dom innehar samma IP-adress. Innebär en hel del problem.

Link to comment
Share on other sites

Det är möjligt att dom stör varandra men borde inte det visat sig tidigare under de fem år kombinationen fungerat utan problem?

 

För övrigt är modemet återställt; det var en av de första sakerna jag testade.

 

Men- båda mina modem fungerar nu direkt kopplade till datorn.

Felet bör alltså sitta i routern eller möjligen i kommunikationen mellan modemet och routern.

Link to comment
Share on other sites

Låter ju onekligen som att det är din router som har packat ihop. Det kan hända fast den fysiskt fortfarande verkar fungera... kan vara en strömspik eller åska som till sist tagit ut sin rätt...

Link to comment
Share on other sites

Ja det lutar åt det, men det är ju uppenbart att ytterligare något fel fanns tidigare.

Ska som sagt testa routern på annan plats och sen ska sonen ta med sin hit så att jag kan testa den. Då bör jag i alla fall få reda på om routern packat ihop.

Link to comment
Share on other sites

Ja det lutar åt det, men det är ju uppenbart att ytterligare något fel fanns tidigare.

Ska som sagt testa routern på annan plats och sen ska sonen ta med sin hit så att jag kan testa den. Då bör jag i alla fall få reda på om routern packat ihop.

 

Kanon, detta är felsökning som den ska vara i den högre skolan Tummeupp.gif imponerande....

Link to comment
Share on other sites

Nu skulle jag vilja föra upp mitt problem på en mer principiell nivå :D

Mitt problem har löst sig själv men jag vill förstå (litegrann) i alla fall)

 

 

DHCP fungerade inte varken med eller utan router. Alltså kan inte den vara routern till det onda även om det skulle visa sig att den faktiskt är trasig.

Vad kan internetleverantören gjort som ställt till det?

eller

Vad kan ha hänt samtidigt med 2 macdatorer och tre operativsystem som gjort att det inte går att komma ut via DHCP?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...